DEC
8
2003

KDE 3.2 Beta 2 "Dobra Voda" is Waiting For You

Our first KDE 3.2 Beta "Rudi" was a huge success and resulted in over 2000 resolved bugs. As the code still has some rough edges, we decided to go for another beta. So here it is: Dobra Voda. Please continue reporting problems you see with it, your testing is much appreciated. You can download Dobra Voda at http://download.kde.org/unstable/3.1.94. Currently we have binaries for Fedora, Slackware and SUSE, besides the sources.

Comments

Well after upgrading from KDE3.1.1 to KDE3.1.4, i just couldn't help but rush off to kde 3. But, in order to do that, I had to upgrade a lot of other packages. That includes a newer Qt and glib. Glib worked fine, and qt installed like a breeze, but, now kde wont compile, it spits out a syntax error!

": undefined reference to `QGList::erase(QLNode*)'"
"undefined reference to `QString::arg(long long, int, int) const'"

Now being that I use Qt in all my development, i know QString shoudl work.. So I checked out the documentation for Qt 3.3.0-beta1 (thats the only one i could download), and found the followign problems:

"QList Class Reference (obsolete)
The QList class has been renamed QPtrList in Qt 3.0."

And for QString, I coudln't find a match for the arguments KDE tries to pass to the QString class...

Whats going on?!


By Dreq at Tue, 2004/01/13 - 6:00am

Note: going to http://doc.trolltech.com/3.3/qglist.html takes you to QList, and Qglist is nowhere to be found in the 3.3 documentation..


By Dreq at Tue, 2004/01/13 - 6:00am

Hello,
i've just istalled new KDE on Fedora, everything is fine, but after some time taskbar disapears and (autohide is turned off), i'm new in Linux, so maybe i'v missed sth obvious.
Best regards

Trikster


By Trikster at Tue, 2004/01/13 - 6:00am

(no debugging symbols found)...Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread -1085017216 (LWP 1196)]

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x00ad0c32 in _dl_sysinfo_int80 ()
from /lib/ld-linux.so.2
#0 0x00ad0c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1 0x00d59a03 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2 0x00944da1 in KCrash::defaultCrashHandler(int) ()
from /usr/lib/libkdecore.so.4


By Trikster at Wed, 2004/01/14 - 6:00am

[root@localhost root]# kdeinit kicker
kdeinit: Shutting down running client.
---------------------------------
It looks like dcopserver is already running. If you are sure
that it is not already running, remove /root/.DCOPserver_localhost.localdomain__0
and start dcopserver again.
---------------------------------

QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
KDE Daemon (kded) already running.
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
Reusing existing ksycoca
[root@localhost root]# QWidget (unnamed): deleted while being painted
QPaintDevice: Cannot destroy paint device that is being painted
QWidget (unnamed): deleted while being painted
QPaintDevice: Cannot destroy paint device that is being painted
X Error: RenderBadPicture (invalid Picture parameter) 184
Major opcode: 157
Minor opcode: 6
Resource id: 0x800103
X Error: RenderBadPicture (invalid Picture parameter) 184
Major opcode: 157
Minor opcode: 6
Resource id: 0x800103
X Error: RenderBadPicture (invalid Picture parameter) 184
Major opcode: 157
Minor opcode: 5
Resource id: 0x800103


By Trikster at Thu, 2004/01/15 - 6:00am

But I have to say the media component in 3.2 beta is a total crap.
Not even usable. And a lot of basic errors.


By netghost at Mon, 2004/01/19 - 6:00am

how do i start kwallet manager?


By pvamp at Mon, 2004/05/03 - 5:00am

Pages