JAN
17
2001

Kivio 0.9.2 released

TheKompany has just released kivio-0.9.2.
Kivio is now officially part of KOffice, and the code is in the KOffice CVS as well as links on www.koffice.org. New features include printing, right-mouse-button menus on more tools, double clicking a stencil now puts you in text-edit mode, size and position actions have been moved off the toolbar and into a dock-window, snap to grid is now implemented, better zooming abilities, birds-eye-view of canvas, a zoom manager, and various bug fixes.

Comments

If you click the back button and look to right under "Recent software" you'll see that Aethera 0.9.0 is out too.
Busy Kompany, that one ;-)


By reihal at Wed, 2001/01/17 - 6:00am

Seems like apps.kde.com have been kde-dotted by the overwhelming interest ;-)


By reihal at Wed, 2001/01/17 - 6:00am

I did sent the Aethera announcement to dot this morning, but I guess it hasn't hit yet. I actually sent this Kivio announcement 2 days ago. Sometimes the stuff shows right up, sometimes it takes a little while :), regardless I think dot is a great site, I hit it more than /. these days.


By Shawn Gordon at Wed, 2001/01/17 - 6:00am

Hello again, Shawn. Sorry to have disturbed you plans, I'll shut up about Aethera for now ;-)


By reihal at Wed, 2001/01/17 - 6:00am

Well, the kivio thing was a slight screw-up.

Anyway, we could sure use some more help here at dot.kde.org. Personally, I've been busy lately, and it seems so have others -- I'll see what I can do about getting some active help for the site.

It does help if the articles you submit are formatted/phrased nicely already, otherwise we end up with a big blob of text and someone has to find the time to edit it before posting the story.

In any case please KEEP SUBMITTING ARTICLES! ;-)

Thanks,
Navin.


By Navindra Umanee at Wed, 2001/01/17 - 6:00am

Can anyone get kivio to work on Mandrake 7.2? The last beta worked ok, but this one doesn't even seem to load...


By Eron Lloyd at Thu, 2001/01/18 - 6:00am

Make sure you have totally removed the prior version, we've updated the FAQ to explain this. You could also try compiling the source instead, but make sure you have the old version gone first.


By Shawn Gordon at Thu, 2001/01/18 - 6:00am

Hrmm... still erroring out... just spits out it's shutdown code if launched from the terminal.

[elloyd@localhost elloyd]$ kivio
kdecore (KLibLoader): add loaded lib 0x80966a0
kivio: KivioConfig - created
kivio: KivioConfig::KivioConfig() - StencilBackgroundType: 0
kivio: KivioConfig::KivioConfig() - StencilBackgroundFile:
kivio: KivioConfig::KivioConfig() - StencilBackgroundColor: 75 210 255
kdecore (KLibLoader): Deleting KLibLoader 0x808f0c8 unnamed
kdecore (KLibLoader): The KLibLoader contains the library 0x8099870
kdecore (KLibLoader): Deleting KLibrary 0x8099870 libkiviopart
kdecore (KLibLoader): Factory still has object 0x80a0dd0 Document
kdecore (KLibLoader): ... deleting the factory 0x8099f90
kivio: KivioConfig::~KivioConfig() - deleted
kdecore (KLibLoader): Deleting KLibFactory 0x8099f90
kdecore (KLibLoader): add pending close 0x80966a0
kdecore (KLibLoader): try to dlclose 0x80966a0: yes, done.

I deleted all the files like you said (unless I missed some that are installed elsewhere instead of the Home directory). Guess I'll have to investigate some more :-(


By Eron Lloyd at Thu, 2001/01/18 - 6:00am

Hey Eron,

This is something completely new to me. I've never seen it auto-shutdown like that.

Have you tried installing from the source tarball?

There is one thing I know which needs to be changed though I'm not sure if it is required for the program to work properly (I doubt it). The libraries currently get installed under 'lib' instead of 'modules', or something like that. I've seen messages like this scroll by when I start the program.

-dave


By Dave Marotti at Thu, 2001/01/18 - 6:00am

I haven't done anything since then on it... guess
I could try to compile it - what did you say needed to be changed?


By Eron Lloyd at Fri, 2001/01/19 - 6:00am

Nothing should need to be changed. I was just saying there are some code changes I need to make, actually, Makefile changes. The program complains that it found some libraries in lib, and not modules. I need to change that. But that shouldn't affect your execution of the program.


By Dave Marotti at Mon, 2001/01/22 - 6:00am

Hello,

I develop Kivio under Mandrake 7.2, so I'm pretty sure it works :)

I am however, using CVS versions of KOffice and I don't recall the version of KDE I'm developing with, it may be CVS (older) as well.

-dave


By Dave Marotti at Thu, 2001/01/18 - 6:00am

got that, on a pretty standard M7.2, too.

[luc@mars luc]$ kivio
KivioConfig - created
KivioConfig::KivioConfig() - StencilBackgroundType: 0
KivioConfig::KivioConfig() - StencilBackgroundFile:
KivioConfig::KivioConfig() - StencilBackgroundColor: 75 210 255
KCrash: crashing.... crashRecursionCounter = 2
KCrash: Application Name = kivio path =


By luc at Fri, 2001/01/19 - 6:00am

I had the same trouble with kivio and Mandrake 7.2: here is what I get

[john@jmahon john]$ kivio
KivioConfig - created
KivioConfig::KivioConfig() - StencilBackgroundType: 0
KivioConfig::KivioConfig() - StencilBackgroundFile:
KivioConfig::KivioConfig() - StencilBackgroundColor: 75 210 255
~Kapp: cleanup in the library loader: destruct all factories and unload the libraries (Simon)
KivioConfig::~KivioConfig() - deleted


By John Mahon at Wed, 2001/01/24 - 6:00am