MAR
21
2002

KDE 3.0RC3: Prepare to Fall in Love

The KDE Project has announced the release
of KDE 3.0RC3 (on this, the first day of Spring). The release comes a month after the release of KDE 3.0beta2, with
two (semi-public) release candidates, as well as a well-attended 1-week hacking session for fixing problems, appearing in the interim. KDE 3.0rc3 can be downloaded through KDE's load-balancing system (source code, RedHat packages (only partially uploaded at this time), and SuSE packages). Additional packages should become available in the coming days, both on KDE's and some distributions' servers. Other than for show-stopper fixes, this release candidate will be released
early next month as KDE 3.0. Personal impression: love at first sight,
it simply rocks!

As much as I hate to admit it, with my
busy schedule I have not been able to keep up the KDE 3 releases. But yesterday morning I installed KDE 3.0rc3 and, to be honest, it is truly magnificent!
Konqueror is fast, fast, fast!
Never seen anything like it (except maybe Lynx) in
the main browsers - even
long pages in my Most Often Visited list all but instantly popped into
place.

The rest of KDE 3 is simply spectacular, too. Everything is snappier,
from menus (despite the addition of cool menu icons) and dialogs (these pop up much faster) to applications, and the look is even more professional than KDE 2. Wowwww, I am in total awe. Superb, excellent, amazing job, guys, KDE 3 absolutely rules!

Due to the imminence of the 3.0 release, for this release candidate only, please post crashes and grave bug reports directly to kde-devel@kde.org rather than using the conventional bug reporting system. Let's see who of you can make KDE 3.0 even better by finding any elusive shot-stopper bugs before the end of the week!

Comments

Anyone knows when Redhat packages will be ready ?


By Anonymous at Thu, 2002/03/21 - 6:00am

On many mirrors, the i386 dir is empty...

only here http://gd.tuwien.ac.at/pub/kde/unstable/kde-3.0rc3/RedHat/i386/
I see 47 packages... but, it's a complete distro???


By huntz at Thu, 2002/03/21 - 6:00am

> I see 47 packages... but, it's a complete distro???

No, it's a part of complete KDE release packaged the new RedHat way into several small packages.


By Anonymous at Thu, 2002/03/21 - 6:00am

That's just great... My computer isn't powerful enough to compile from source (read: don't want to spend a whole day to compile it), so I use binaries most the time. 2 days ago I switched to Mandrake because it has better KDE support (and KDE 2.2.2 feels much faster now :-). I always wanted to test the new 3.0 (Beta/RC) but RH never released binaries for it. And now suddenly RH does, and Mandrake doesn't :-(

I guess I have to wait for Mandrake to release 3.0 final... or RC3 if they want to package it. No, I won't test an old Beta...


By Andy Goossens at Thu, 2002/03/21 - 6:00am

... or you could wait and switch (again ;-) to SuSE 8.0. It is annouced to be released with KDE 3.0 final.


By sikasso at Thu, 2002/03/21 - 6:00am

While I'd like that also, the lifespan of this one isn't very long. They're looking for last minute bug testing from the main source branch, so getting reports on a specific RPM version might not be as helpful for now.

I'd prefer a 2 week test cycle myself, including binaries, but I'm not a KDE developer so my opinion matters naught.


By Anonymous at Thu, 2002/03/21 - 6:00am

Most likely a month or two after final. They are usually a little behind. When you consider the qa that must go into building a package that will work 99% of the time, this is a fairly reasonable amount of time.

thx,
Neil


By Neil Davis at Thu, 2002/03/21 - 6:00am

BTW, I get:

[root@dimi KDE3rc3]# rpm -ivh *.rpm
error: failed dependencies:
libgphoto2.so.2 is needed by kamera-3.0-0.rc3.1
libgphoto2_port.so.0 is needed by kamera-3.0-0.rc3.1
libusb-0.1.so.4 is needed by kamera-3.0-0.rc3.1
libxml2 >= 2.4.12 is needed by kdebase-3.0-0.rc3.1
cups-libs >= 1.1.12 is needed by kdelibs-3.0-0.rc3.1
libusb-0.1.so.4 is needed by kooka-3.0-0.rc3.1
libusb-0.1.so.4 is needed by libkscan-3.0-0.rc3.1

The important stuff here is
libxml2 >= 2.4.12 is needed by kdebase-3.0-0.rc3.1
cups-libs >= 1.1.12 is needed by kdelibs-3.0-0.rc3.1

Where can I get them from? :)


By themetaguy at Thu, 2002/03/21 - 6:00am


By bd at Fri, 2002/03/22 - 6:00am

But I did. I searched

http://rpmfind.net

as well as Bero's

http://www.linux-easy.com

Nada. At least for RedHat 7.2


By themetaguy at Fri, 2002/03/22 - 6:00am

The problem is that the only packeger on redhat that cares a lot about kde is bero, and he's always using a distro with all updates from rawhide.
This means RedHat rpms are not for kde 7.2, but for rawhide.
This is why I'm going to chance for mdk 8.2 soon :)


By Iuri Fiedoruk at Fri, 2002/03/22 - 6:00am

Can anyone tell me the correct rpm commands to install KDE3 on RH 7.2. I get a
lot of conflicts and dependancy problems.


By BOBS at Fri, 2002/03/22 - 6:00am

But what conflicts and dependancy you get?


By Tyro at Fri, 2002/03/22 - 6:00am

Below are the outputs from my two attempts of installing KDE3 on a freshly installed RH 7.2 machine. using rpm -U *.rpm and rpm -U --nodeps *.rpm.

One combination of rpm options (which I've unfortunately forgotten) did appear to install KDE. After reboot I had a new login screen, with icons for each user. Unfortunatly KDE was not an available session type. This led me to reload RH and try again.

Anty advice on avoiding these problems is welcome.

Cheers

Bob

The intial attmpt gave me this

[root@snooker kde3]# rpm -U *.rpm
error: failed dependencies:
libcups.so.2 is needed by kaboodle-3.0-0.rc3.1
libcups.so.2 is needed by kamera-3.0-0.rc3.1
libgphoto2.so.2 is needed by kamera-3.0-0.rc3.1
libgphoto2_port.so.0 is needed by kamera-3.0-0.rc3.1
libusb-0.1.so.4 is needed by kamera-3.0-0.rc3.1
libcups.so.2 is needed by kcoloredit-3.0-0.rc3.1
libcups.so.2 is needed by kdeaddons-kate-3.0-0.rc3.1
libcups.so.2 is needed by kdeaddons-kicker-3.0-0.rc3.1
kdenetwork-libs >= 3.0 is needed by kdeaddons-knewsticker-3.0-0.rc3.1
knewsticker >= 3.0 is needed by kdeaddons-knewsticker-3.0-0.rc3.1
libcups.so.2 is needed by kdeaddons-konqueror-3.0-0.rc3.1
libcups.so.2 is needed by kdeaddons-noatun-3.0-0.rc3.1
libcups.so.2 is needed by kdeadmin-3.0-0.rc3.1
librpm-4.0.4.so is needed by kdeadmin-3.0-0.rc3.1
librpmbuild-4.0.4.so is needed by kdeadmin-3.0-0.rc3.1
librpmdb-4.0.4.so is needed by kdeadmin-3.0-0.rc3.1
librpmio-4.0.4.so is needed by kdeadmin-3.0-0.rc3.1
libcups.so.2 is needed by kdeartwork-3.0-0.rc3.1
libcups.so.2 is needed by kdeartwork-screensavers-3.0-0.rc3.1
libxml2 >= 2.4.12 is needed by kdebase-3.0-0.rc3.1
libcups.so.2 is needed by kdebase-3.0-0.rc3.1
libqt.so.3 is needed by kdebase-3.0-0.rc3.1
qt >= 3.0.3 is needed by kdelibs-3.0-0.rc3.1
cups-libs >= 1.1.12 is needed by kdelibs-3.0-0.rc3.1
libcups.so.2 is needed by kdelibs-3.0-0.rc3.1
qt-devel >= 3.0.3 is needed by kdelibs-devel-3.0-0.rc3.1
libcups.so.2 is needed by kdelibs-devel-3.0-0.rc3.1
libcups.so.2 is needed by kdemultimedia-arts-3.0-0.rc3.1
libcups.so.2 is needed by kdemultimedia-kfile-3.0-0.rc3.1
libcups.so.2 is needed by kdetoys-3.0-0.rc3.1
libcups.so.2 is needed by kdvi-3.0-0.rc3.1
libcups.so.2 is needed by kfax-3.0-0.rc3.1
libcups.so.2 is needed by kfile-pdf-3.0-0.rc3.1
libcups.so.2 is needed by kfile-png-3.0-0.rc3.1
libcups.so.2 is needed by kfract-3.0-0.rc3.1
libcups.so.2 is needed by kghostview-3.0-0.rc3.1
libcups.so.2 is needed by kiconedit-3.0-0.rc3.1
libcups.so.2 is needed by kmid-3.0-0.rc3.1
libcups.so.2 is needed by kmidi-3.0-0.rc3.1
libcups.so.2 is needed by kmix-3.0-0.rc3.1
libcups.so.2 is needed by koncd-3.0-0.rc3.1
libcups.so.2 is needed by kooka-3.0-0.rc3.1
libusb-0.1.so.4 is needed by kooka-3.0-0.rc3.1
libcups.so.2 is needed by kpaint-3.0-0.rc3.1
libcups.so.2 is needed by kruler-3.0-0.rc3.1
libcups.so.2 is needed by kscd-3.0-0.rc3.1
libcups.so.2 is needed by ksnapshot-3.0-0.rc3.1
libcups.so.2 is needed by kuickshow-3.0-0.rc3.1
libcups.so.2 is needed by kview-3.0-0.rc3.1
libcups.so.2 is needed by kviewshell-3.0-0.rc3.1
libcups.so.2 is needed by libkscan-3.0-0.rc3.1
libusb-0.1.so.4 is needed by libkscan-3.0-0.rc3.1
libcups.so.2 is needed by noatun-3.0-0.rc3.1
libartsflow_idl.so.0 is needed by kdegames-2.2-2
libartsflow.so.0 is needed by kdegames-2.2-2
libkmedia2_idl.so.0 is needed by kdegames-2.2-2
libmcop.so.0 is needed by kdegames-2.2-2
libsoundserver_idl.so.0 is needed by kdegames-2.2-2
libDCOP.so.1 is needed by kdepim-2.2-1
libDCOP.so.1 is needed by koffice-1.1-5
libDCOP.so.1 is needed by kdeutils-2.2-2
libDCOP.so.1 is needed by kdenetwork-2.2-7
libDCOP.so.1 is needed by kdenetwork-ppp-2.2-7
libDCOP.so.1 is needed by kpppload-1.04-29
libDCOP.so.1 is needed by kdebindings-2.2-2
libDCOP.so.1 is needed by kdebindings-kmozilla-2.2-2
libDCOP.so.1 is needed by licq-kde-1.0.3-7
libDCOP.so.1 is needed by kdegraphics-2.2-1
libDCOP.so.1 is needed by kdbg-1.2.1-5
libDCOP.so.1 is needed by kdesdk-2.2-2
libDCOP.so.1 is needed by kdevelop-2.0-1
libDCOP.so.1 is needed by kdegames-2.2-2
libDCOP.so.1 is needed by cervisia-1.4.1-2
libDCOP.so.1 is needed by kdebindings-perl-2.2-2
libDCOP.so.1 is needed by kdepim-cellphone-2.2-1
libDCOP.so.1 is needed by kdepim-pilot-2.2-1
libDCOP.so.1 is needed by kdebindings-python-2.2-2
libDCOP.so.1 is needed by quanta-2.0-0.cvs20010724.2
libkab.so.3 is needed by kdepim-2.2-1
libkab.so.3 is needed by kdeutils-2.2-2
libkab.so.3 is needed by kdenetwork-2.2-7
libkab.so.3 is needed by kdepim-cellphone-2.2-1
libkdecore.so.3 is needed by kdepim-2.2-1
libkdecore.so.3 is needed by koffice-1.1-5
libkdecore.so.3 is needed by kdeutils-2.2-2
libkdecore.so.3 is needed by kdenetwork-2.2-7
libkdecore.so.3 is needed by kdenetwork-ppp-2.2-7
libkdecore.so.3 is needed by kpppload-1.04-29
libkdecore.so.3 is needed by kdebindings-2.2-2
libkdecore.so.3 is needed by kdebindings-kmozilla-2.2-2
libkdecore.so.3 is needed by licq-kde-1.0.3-7
libkdecore.so.3 is needed by kdegraphics-2.2-1
libkdecore.so.3 is needed by kdbg-1.2.1-5
libkdecore.so.3 is needed by kdesdk-2.2-2
libkdecore.so.3 is needed by kdevelop-2.0-1
libkdecore.so.3 is needed by kdegames-2.2-2
libkdecore.so.3 is needed by cervisia-1.4.1-2
libkdecore.so.3 is needed by kdebindings-perl-2.2-2
libkdecore.so.3 is needed by kdepim-cellphone-2.2-1
libkdecore.so.3 is needed by kdepim-pilot-2.2-1
libkdecore.so.3 is needed by quanta-2.0-0.cvs20010724.2
libkdefakes.so.3 is needed by cervisia-1.4.1-2
libkdeprint.so.0 is needed by kdepim-2.2-1
libkdeprint.so.0 is needed by koffice-1.1-5
libkdeprint.so.0 is needed by kdeutils-2.2-2
libkdeprint.so.0 is needed by kdenetwork-2.2-7
libkdeprint.so.0 is needed by kdegraphics-2.2-1
libkdeprint.so.0 is needed by kdevelop-2.0-1
libkdeprint.so.0 is needed by kdegames-2.2-2
libkdeprint.so.0 is needed by quanta-2.0-0.cvs20010724.2
libkdesu.so.1 is needed by kdepim-2.2-1
libkdesu.so.1 is needed by koffice-1.1-5
libkdesu.so.1 is needed by kdeutils-2.2-2
libkdesu.so.1 is needed by kdenetwork-2.2-7
libkdesu.so.1 is needed by kdebindings-2.2-2
libkdesu.so.1 is needed by kdebindings-kmozilla-2.2-2
libkdesu.so.1 is needed by licq-kde-1.0.3-7
libkdesu.so.1 is needed by kdegraphics-2.2-1
libkdesu.so.1 is needed by kdbg-1.2.1-5
libkdesu.so.1 is needed by kdesdk-2.2-2
libkdesu.so.1 is needed by kdevelop-2.0-1
libkdesu.so.1 is needed by kdegames-2.2-2
libkdesu.so.1 is needed by cervisia-1.4.1-2
libkdesu.so.1 is needed by kdepim-cellphone-2.2-1
libkdesu.so.1 is needed by kdepim-pilot-2.2-1
libkdesu.so.1 is needed by quanta-2.0-0.cvs20010724.2
libkdeui.so.3 is needed by kdepim-2.2-1
libkdeui.so.3 is needed by koffice-1.1-5
libkdeui.so.3 is needed by kdeutils-2.2-2
libkdeui.so.3 is needed by kdenetwork-2.2-7
libkdeui.so.3 is needed by kdenetwork-ppp-2.2-7
libkdeui.so.3 is needed by kpppload-1.04-29
libkdeui.so.3 is needed by kdebindings-2.2-2
libkdeui.so.3 is needed by kdebindings-kmozilla-2.2-2
libkdeui.so.3 is needed by licq-kde-1.0.3-7
libkdeui.so.3 is needed by kdegraphics-2.2-1
libkdeui.so.3 is needed by kdbg-1.2.1-5
libkdeui.so.3 is needed by kdesdk-2.2-2
libkdeui.so.3 is needed by kdevelop-2.0-1
libkdeui.so.3 is needed by kdegames-2.2-2
libkdeui.so.3 is needed by cervisia-1.4.1-2
libkdeui.so.3 is needed by kdepim-cellphone-2.2-1
libkdeui.so.3 is needed by kdepim-pilot-2.2-1
libkdeui.so.3 is needed by quanta-2.0-0.cvs20010724.2
libkfile.so.3 is needed by kdepim-2.2-1
libkfile.so.3 is needed by koffice-1.1-5
libkfile.so.3 is needed by kdeutils-2.2-2
libkfile.so.3 is needed by kdenetwork-2.2-7
libkfile.so.3 is needed by kdebindings-2.2-2
libkfile.so.3 is needed by kdebindings-kmozilla-2.2-2
libkfile.so.3 is needed by licq-kde-1.0.3-7
libkfile.so.3 is needed by kdegraphics-2.2-1
libkfile.so.3 is needed by kdbg-1.2.1-5
libkfile.so.3 is needed by kdesdk-2.2-2
libkfile.so.3 is needed by kdevelop-2.0-1
libkfile.so.3 is needed by kdegames-2.2-2
libkfile.so.3 is needed by cervisia-1.4.1-2
libkfile.so.3 is needed by kdepim-cellphone-2.2-1
libkfile.so.3 is needed by kdepim-pilot-2.2-1
libkfile.so.3 is needed by quanta-2.0-0.cvs20010724.2
libkhtml.so.3 is needed by kdenetwork-2.2-7
libkhtml.so.3 is needed by kdevelop-2.0-1
libkhtml.so.3 is needed by quanta-2.0-0.cvs20010724.2
libkio.so.3 is needed by kdepim-2.2-1
libkio.so.3 is needed by koffice-1.1-5
libkio.so.3 is needed by kdeutils-2.2-2
libkio.so.3 is needed by kdenetwork-2.2-7
libkio.so.3 is needed by kdebindings-2.2-2
libkio.so.3 is needed by kdebindings-kmozilla-2.2-2
libkio.so.3 is needed by licq-kde-1.0.3-7
libkio.so.3 is needed by kdegraphics-2.2-1
libkio.so.3 is needed by kdbg-1.2.1-5
libkio.so.3 is needed by kdesdk-2.2-2
libkio.so.3 is needed by kdevelop-2.0-1
libkio.so.3 is needed by kdegames-2.2-2
libkio.so.3 is needed by cervisia-1.4.1-2
libkio.so.3 is needed by kdepim-cellphone-2.2-1
libkio.so.3 is needed by kdepim-pilot-2.2-1
libkio.so.3 is needed by quanta-2.0-0.cvs20010724.2
libkparts.so.1 is needed by kdepim-2.2-1
libkparts.so.1 is needed by koffice-1.1-5
libkparts.so.1 is needed by kdeutils-2.2-2
libkparts.so.1 is needed by kdenetwork-2.2-7
libkparts.so.1 is needed by kdebindings-2.2-2
libkparts.so.1 is needed by kdebindings-kmozilla-2.2-2
libkparts.so.1 is needed by kdegraphics-2.2-1
libkparts.so.1 is needed by kdevelop-2.0-1
libkparts.so.1 is needed by kdegames-2.2-2
libkparts.so.1 is needed by quanta-2.0-0.cvs20010724.2
libkspell.so.3 is needed by koffice-1.1-5
libkspell.so.3 is needed by kdeutils-2.2-2
libkspell.so.3 is needed by kdenetwork-2.2-7
libkspell.so.3 is needed by kdesdk-2.2-2
libkspell.so.3 is needed by quanta-2.0-0.cvs20010724.2
libkssl.so.2 is needed by kdepim-2.2-1
libkssl.so.2 is needed by koffice-1.1-5
libkssl.so.2 is needed by kdeutils-2.2-2
libkssl.so.2 is needed by kdenetwork-2.2-7
libkssl.so.2 is needed by kdebindings-2.2-2
libkssl.so.2 is needed by kdebindings-kmozilla-2.2-2
libkssl.so.2 is needed by licq-kde-1.0.3-7
libkssl.so.2 is needed by kdegraphics-2.2-1
libkssl.so.2 is needed by kdbg-1.2.1-5
libkssl.so.2 is needed by kdesdk-2.2-2
libkssl.so.2 is needed by kdevelop-2.0-1
libkssl.so.2 is needed by kdegames-2.2-2
libkssl.so.2 is needed by kdepim-cellphone-2.2-1
libkssl.so.2 is needed by kdepim-pilot-2.2-1
libkssl.so.2 is needed by quanta-2.0-0.cvs20010724.2
libksycoca.so.3 is needed by kdepim-2.2-1
libksycoca.so.3 is needed by koffice-1.1-5
libksycoca.so.3 is needed by kdeutils-2.2-2
libksycoca.so.3 is needed by kdenetwork-2.2-7
libksycoca.so.3 is needed by kdebindings-2.2-2
libksycoca.so.3 is needed by kdebindings-kmozilla-2.2-2
libksycoca.so.3 is needed by licq-kde-1.0.3-7
libksycoca.so.3 is needed by kdegraphics-2.2-1
libksycoca.so.3 is needed by kdbg-1.2.1-5
libksycoca.so.3 is needed by kdesdk-2.2-2
libksycoca.so.3 is needed by kdevelop-2.0-1
libksycoca.so.3 is needed by kdegames-2.2-2
libksycoca.so.3 is needed by cervisia-1.4.1-2
libksycoca.so.3 is needed by kdepim-cellphone-2.2-1
libksycoca.so.3 is needed by kdepim-pilot-2.2-1
libksycoca.so.3 is needed by quanta-2.0-0.cvs20010724.2
libqtmcop.so.0 is needed by kdegames-2.2-2
[root@snooker kde3]#

The 2nd attepmpt gave this *****************************

[root@snooker kde3]# rpm -U --nodeps *.rpm
file /usr/lib/libvcard.la from install of kdelibs-3.0-0.rc3.1 conflicts with file from package kdepim-2.2-1
file /usr/lib/libvcard.so.0.0.0 from install of kdelibs-3.0-0.rc3.1 conflicts with file from package kdepim-2.2-1
file /usr/share/mimelnk/application/x-abiword.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kchart.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kformula.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kivio.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kontour.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kpresenter.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kspread.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kugar.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-kword.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/application/x-quattropro.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/image/x-msod.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/image/x-wmf.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/image/x-xfig.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/share/mimelnk/text/x-csv.desktop from install of kdelibs-3.0-0.rc3.1 conflicts with file from package koffice-1.1-5
file /usr/bin/kcolorchooser from install of kcoloredit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kcoloredit from install of kcoloredit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/kcolorchooser.la from install of kcoloredit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/kcolorchooser.so from install of kcoloredit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kcolorchooser.desktop from install of kcoloredit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kcoloredit.desktop from install of kcoloredit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kfind from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/bin/kpm from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/share/applnk/Kfind.desktop from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/share/doc/HTML/en/kfind/index.cache.bz2 from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/share/doc/HTML/en/kfind/index.docbook from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/share/icons/hicolor/32x32/apps/kfind.png from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/share/icons/hicolor/48x48/apps/kfind.png from install of kdebase-3.0-0.rc3.1 conflicts with file from package kdeutils-2.2-2
file /usr/bin/kfract from install of kfract-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kfract.desktop from install of kfract-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kfract/index.cache.bz2 from install of kfract-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kfract/index.docbook from install of kfract-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kghostview from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkghostview.la from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkghostview.so from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kghostview.desktop from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/apps/kghostview/kghostviewui.rc from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/apps/kghostview/kgv_part.rc from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kghostview/index.cache.bz2 from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kghostview/index.docbook from install of kghostview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kiconedit from install of kiconedit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kiconedit.desktop from install of kiconedit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kiconedit/index.cache.bz2 from install of kiconedit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kiconedit/index.docbook from install of kiconedit-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kpaint from install of kpaint-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kpaint.desktop from install of kpaint-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kpaint/index.cache.bz2 from install of kpaint-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kpaint/index.docbook from install of kpaint-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kruler from install of kruler-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kruler.desktop from install of kruler-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/apps/kruler/eventsrc from install of kruler-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kruler/index.cache.bz2 from install of kruler-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kruler/index.docbook from install of kruler-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/ksnapshot from install of ksnapshot-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/ksnapshot.desktop from install of ksnapshot-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/ksnapshot/index.cache.bz2 from install of ksnapshot-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/ksnapshot/index.docbook from install of ksnapshot-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kview from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/kview.la from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/kview.so from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkviewpart.la from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkviewpart.so from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kview.desktop from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/apps/kview/kviewui.rc from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kview/index.cache.bz2 from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kview/index.docbook from install of kview-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kviewshell from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkmultipage.la from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkmultipage.so.0.0.0 from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkpagetest.la from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkpagetest.so from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkviewerpart.la from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkviewerpart.so from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkviewpart.la from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkviewpart.so from install of kviewshell-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kdvi from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkdvi.la from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkdvi.so from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kdvi.desktop from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/apps/kdvi/kdvi_part.rc from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kdvi/KDVI-features.dvi from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kdvi/KDVI-features.tex from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kdvi/index.cache.bz2 from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kdvi/index.docbook from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kdvi/optionrequester1.png from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/doc/HTML/en/kdvi/optionrequester2.png from install of kdvi-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kfax from install of kfax-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkfax.la from install of kfax-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkfax.so from install of kfax-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/applnk/Graphics/kfax.desktop from install of kfax-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkscan.la from install of libkscan-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/lib/libkscan.so.1.0.0 from install of libkscan-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/bin/kooka from install of kooka-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/share/apps/kooka/kookaui.rc from install of kooka-3.0-0.rc3.1 conflicts with file from package kdegraphics-2.2-1
file /usr/include/kde/devselector.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/dispgamma.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/gammadialog.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/img_canvas.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/kgammatable.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/kscandevice.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/kscanoption.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/kscanoptset.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/kscanslider.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/massscandialog.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/previewer.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1
file /usr/include/kde/scanparams.h from install of libkscan-devel-3.0-0.rc3.1 conflicts with file from package kdegraphics-devel-2.2-1


By BOBS at Sat, 2002/03/23 - 6:00am

check rpmfind.net

As example
for libcups.so.2 you need install this package
be http://rpmfind.net//linux/RPM/rhcontrib/7.1/i386/cups-1.1.10-3.i386.html
for libgphoto2.so.2 - ftp.gmd.de/mirrors/redhat.com/redhat/linux/rawhide/i386/RedHat/RPMS/gphoto2-2.0-2.i386.rpm
(In this case first I go to the rpmfind.net and chaeck libgphoto2.so.2 thin i see
3 package libgphoto2-2.0-2mdk.ppc.rpm
libgphoto2-2.0-2mdk.i586.rpm
gphoto2-2.0-2.alpha.rpm
but we need package for RH, so i go to ftpfind.com and check gphoto2-2.0 and
find this ftp.join.uni-muenster.de/pub/mirrors/ftp.redhat.com/redhat/linux/rawhide/i386/RedHat/RPMS/gphoto2-2.0-2.i386.rpm)
and e.t.c.

So and of cause you need to install qt 3.0.3
And never use --nodeps it's danger!!!
If you have more question u can mail me
Good luck!


By Tyro at Sat, 2002/03/23 - 6:00am

Could you please post an URL where one can find the qt-3.x package for Red Hat 7.2 on an i386? I've been looking around RPMfind.net and I can find it for almost any distro (including Alpha64) but not for that one.

Thanks in advance!


By Ricardo J. Méndez at Mon, 2002/03/25 - 6:00am

Thanks!


By Ricardo J. Méndez at Tue, 2002/03/26 - 6:00am

Install do not work... the dep packages is very big... I'm have amost of problems here... why?

the package send xxxx depend xxxx2 to work... you get xxxx2...
the package send xxxx2 depend xxxx to work??????????????? :P

What command line is correct... "rpm -ivh *.rpm" or "rpm -Uvh *.rpm" or another...?

There is not have finish... is a forever loop... Please help me!!!!!! :(

Best regards

Jean


By Jean Pierre at Sat, 2002/03/30 - 6:00am

Nice to learn that a new RC is out.... BUT WHY DOESN'T KDE MENTIONS THE RC ON THE WEB SITE?

I mean... the last announcement was for the Beta2.
I've seen no RC announcement so far (even on the archives on the mailing-lists I've just browsed).

What's the purpose of a RC? Having the programs to be tested by the biggest number of people, or keep them secret?

I don't get it, can someone explain me. I'm a moderator on a news site, and we have passed every single news on Mandrake 8.2 betas and RC. We would have done the same for KDE if we had heard of these RC (with some official announcements, like changes...)


By oliv at Thu, 2002/03/21 - 6:00am

Well, actually they were announced. But because they were semi-public you won't find them on the news-page. Just look on the developerpages or the release-schedule. Everything is there. And the best: appointed times are almost always abided... ;-)

CU
Marcel


By Marcel at Thu, 2002/03/21 - 6:00am

Well, at least translators were notified about
tagging RC-releases, these were well-known there.
Anyways, I don't think there were binary packages,
so that's the reason they were semi-public.


By Juraj Bednar at Sun, 2002/03/24 - 6:00am

Of course, I wont be running KDE3 in a while. Knowing Debian, it will take a while before they make packages available. But what I have learned of KDE 3 sounds REALLY promising! New features, new eye-candy, more speed... What more could you ask for?

I hope Konqueror finally has the one feature I have been waiting for. When right-clicking on a thumbnail (for example), and choosing "new window", it should open it in new Konqueror-windows (well duh!) and not ask what app to use to open it. If I choose "new window" in Konqueror, naturally I mean new Konqueror-window.


By Janne at Thu, 2002/03/21 - 6:00am

Compile it from source. Debian's kde packages introduced new bugs, and were slow to be released (esp if you use stable). It may take a few hours to compile, but you get KDE now, and you get it optimised for your system, and it is easy to do.


By eze at Thu, 2002/03/21 - 6:00am

But then you've got to recompile with every release and in KDE world, that's pretty often! The beauty of Debian is the easy maintenance. Upgrading is sooo simple; one would hate to interfere with that!


By justMe at Fri, 2002/03/22 - 6:00am

So install it into a non-Debian path (like /opt/kde) and keep the recent qt-copy out of /usr/lib and you're set. When Debian releases the packages, just install the packages and rm -rf /opt/kde. This way you get all the betas and release candidates you can shake a stick at and still keep up with the Debian way when they catch up.


By cosmo at Sat, 2002/03/23 - 6:00am

That right-click thing should already work in 2.2.
Maybe it's the application/bmp vs application/x-bmp misnaming?
I noticed it and fixed it in CVS recently.
Or does it do that for all kind of images ?

(Also, make sure that the setting in "File Associations" is still "Use embedded viewer" for images).


By David Faure at Thu, 2002/03/21 - 6:00am

Thanks, I check out those settings today :). It has been with just about all kinds of images (gif, jpg, png etc.). That has been just about the only thing that has annoyed me in Konqueror (well, there are some javascript-problems with some sites, but I expect those to be fixed in 3.0).


By Janne at Fri, 2002/03/22 - 6:00am

I made sure that the images in question use the embedded viewer but no help (that setting was for left-click action, I haven't found setting for right-click action). I also made sure that the imagetypes in question are opened in Konqueror, but it doesn't help. It seems like it tries to open new Konqueror-window, but it never does :(. Oh well, that's a minor issue and I can live with it.


By Janne at Fri, 2002/03/22 - 6:00am

If you want to open an image in a new Konqueror window, not in a external viewer, then don't choose "new window" in the popup menu, but use the middel mouse button in stead. Works fine for me ;)

Rinse


By rinse at Fri, 2002/03/22 - 6:00am

Thanks for the tip!


By cgen at Sat, 2002/03/23 - 6:00am

Thanks, it works :). Also, since I wasn't able to get the RMB to work, I decided to revert my settings to their default values. After I did, the RMB suddenly started to work! Talk about strange!


By Janne at Sat, 2002/03/23 - 6:00am

If you want to run KDE - use alien to convert the Red Hat RPM file to Deb files ;-)

Thanks,
Alex


By Alex Howells at Mon, 2002/04/01 - 6:00am

I have two quick questions about kde3,rc since I can't install it at the moment.

1. It was mentioned that Konqueror and the rest of KDE3 are "fast, fast, fast". What is the reason for such a speed increase? Is it obj-prelinked? If not, can additional gains be made by obj-prelinking?

2. Now to my personal pet-pieve bug in Konq. I am wondering if the "style=display:..." is fixed in Konq 3.0. It was almost fixed in 2.2.x where it worked 50% of the time. For instance, does the sidebar in www.vbrad.com work? It makes heavy use of "style=display:..." to show and hide collapsible lists. Can anyone confirm whether it is fixed or not?


By Frank Rizzo at Thu, 2002/03/21 - 6:00am

>I am wondering if the "style=display:..." is fixed in Konq 3.0. It was almost fixed in
>2.2.x where it worked 50% of the time. For instance, does the sidebar in www.vbrad.com
>work? It makes heavy use of "style=display:..." to show and hide collapsible lists. Can
>anyone confirm whether it is fixed or not?

Yes, it appears to work.


By Brent Cook at Thu, 2002/03/21 - 6:00am

I tried out the site you mentioned and it seems to work with my CVS build from 08/03/02. Not supprising since Javascript/DOM has been much improved. Everything is much more responsive in KDE3, even without compiling with --enable-Objprelink (it has, in previous CVS builds, caused segmentation faults, so I have stayed away from it for now)


By eze at Thu, 2002/03/21 - 6:00am

Does objectprelinking work yet?

I found that everytime I compiled kde or qt with objprelinking the programs instantly seg faulted when I ran them. Qt wouldnt compile because moc and uic were segfaulting. This happened when compiling beta2 and since then I havent bothered to try prelinking RC1, RC2 or RC3. RC3 is good but it needs objprelinking to make it super fast.

Im using gcc 2.95.4 20011006 (Debian) according to kde.

~Mike


By Mike at Fri, 2002/03/22 - 6:00am

This happened to me too, using Mandrake-7.1. The reason is apparently a too old libc.


By jd at Sat, 2002/03/23 - 6:00am

It used to works on Redhat 7.1 but now im running Debian unstable.
I just finished compiling Kde from cvs today so Ill try prelinking it next time.

~Mike


By Mike at Sat, 2002/03/23 - 6:00am

>1. It was mentioned that Konqueror and the rest of KDE3 are "fast, fast, fast". What is the reason for such a speed increase? Is it obj-prelinked? If not, can additional gains be made by obj-prelinking?

Obj-prelinking is a compile stage optimization. KDE provides source. Whether or not
any version of KDE is obj-prelinked is at the mercy of the packagers, who are the only
ones who provide binaries (since KDE does not). I dunno if it still works with KDE3 tho.


By Carbon at Fri, 2002/03/22 - 6:00am

As far as I can tell the sidebar at http://www.vbrad.com works fine in this instance of konqueror... (3.0beta2) and I've been observing similar behaviours on (yeeha) my tdcanadatrust (webbanking) site that were NOT present in 2.2.2 ...


By Alistair Tonner at Sat, 2002/03/23 - 6:00am

Does anyone know how to get this mysterious keramik style going? It doesn't show up in the control-center but there's a themerc-file in the kstyle dir. Any ideas?


By DennisJ at Thu, 2002/03/21 - 6:00am

IIRC, you should go to kdelibs/kstyle/keramik and then make ; make install manually


By cristian at Thu, 2002/03/21 - 6:00am

The keramik style has been removed from KDE 3.0 as it wasn't ready for release.


By Ingo Klöcker at Mon, 2002/03/25 - 6:00am

you are probably busy, but i had to write a response here.

your keramik style is beautiful. wow. please don't give up on it. i'll just have to get along with liquid until this is finished. not that liquid is bad. it was my favourite until i saw keramik. but i am really looking forward to the finished version of keramik. it almost makes me want to run kde on my win2k partition.

good work.


By subgeek at Thu, 2002/04/04 - 6:00am

As usual.. any screenshots?? I don't have enough bandwidth to download by would like to see how kde glorify. :)

long live kde.
-dmn


By dmn at Thu, 2002/03/21 - 6:00am

Wow. Really nice !! :-) ...

Too bad those new "logout"/"lock screen" icons have such a taste of Windows XP. I feel they are quite in contradiction with the default look and design...
Is it just me ?


By Germain at Fri, 2002/03/22 - 6:00am

I agree! They seem very XP-y, and do clash with the rest of the design.

What's more, some app icons (such as Kmail) seem to have undergone an XP/OSX high-resolution makeover, particularly with the absence of the traditional "colored-in black outline" cartoon look typical with pre-XP/OSX OS's, but other icons (such as KWord) have kept the old look.


By Leo at Sat, 2002/03/23 - 6:00am

Actually, if you look, the only app icon that have deviated from the regular app icon style is the KMail icon. This seems to be because the KMail icon is from Everaldo's glassy icon set, for some reason, whereas the others are not.


By Carbon at Sun, 2002/03/24 - 6:00am

Pages