MAR
10
2004

KDE 3.2.1 is Released

The KDE project today announced the immediate availability of KDE 3.2.1, a maintenance release for the latest generation of the most advanced and powerful free desktop for GNU/Linux and other UNIXes. KDE 3.2.1 ships with lot of bug fixes since KDE 3.2 and is available in 49 languages (now including Bengali, Icelandic, Japanese, Lithuanian, Low Saxon, Latin Serbian and Tajik). Sources and contributed packages are linked on the KDE 3.2.1 info page.

Comments

is Hindi included as language ????????!??


By chris at Tue, 2004/03/09 - 6:00am

Yes, how long did you search?


By Anonymous at Tue, 2004/03/09 - 6:00am

the packages (hi) was not able to compile.


By chris at Wed, 2004/03/10 - 6:00am

It works on my box


By JC at Wed, 2004/03/10 - 6:00am

kde really relaay rocks!!!
i love it

thanx again.
gunnar


By gunnar at Tue, 2004/03/09 - 6:00am

Great, hopefully some rpm's for MDK9.2 will show up soon. I do have a question about Kontact though. I think I saw where there will eventually be a plugin for Exchange server. Any estimate on when that might happen?

Paul.....


By cirehawk at Tue, 2004/03/09 - 6:00am

Just go compile it. It's less fraught with problems...

Just remember to add to the beginning of your path:
/usr/local/kde


By Joe at Tue, 2004/03/09 - 6:00am

I'm not sure what you mean Joe. Are you saying the plugin source is available for compiling? If so, not sure where to get it as I didn't really see it on the Kontact site. Also, I thought I read where the current plugin is for using only the calendar with Exchange. I'm interested in getting email as well. Thanks for your input!

Paul.....


By cirehawk at Wed, 2004/03/10 - 6:00am

I think he was saying that compiling KDE is better than using RPMs. I don't think he was talking about the plugin at all.


By Ed Moyse at Wed, 2004/03/10 - 6:00am

Or better, specify the correct prefix for Mandrake (/usr) when running configure.


By Stephen Douglas at Wed, 2004/03/10 - 6:00am

No. That would overwrite the files from your RPMS, which you should still hang onto, so you can always go back to them. I was offering advice to an obvious newb, and he should leave himself an escape hatch. Source is great, since you can compile for your arch, for example mine is a P4. I think I am the only guy running Linux on a P4.


By Joe at Wed, 2004/03/10 - 6:00am

/usr/local is for locally installed programs. Distributer maintained packages go into the distro's default. However, anything you download the tarballs to, compile, and install (without first making RPM's following distro guidelines) should go into /usr/local...

In other words, don't install crap into /usr unless its an RPM from your distributer. That is what /usr/local is for.


By anon at Wed, 2004/03/10 - 6:00am

This is great newbie info. I have not seen it stated more clearly than in anon:s post above. Is this info prominently displayed somewhere, maybe in the build instructions? Perhaps it should.


By newbie+ at Wed, 2004/03/10 - 6:00am

on debian sid I have no menu entry for kontact...
also kappfinder does not "find" it...


By ac at Wed, 2004/03/10 - 6:00am

If you have the kontact package installed then this sounds like a packaging error.


By Anonymous at Thu, 2004/03/11 - 6:00am

Low Saxon? Segg mol, plattdüütsch is in KDE, KDE op platt.

Tse!


By Jan at Tue, 2004/03/09 - 6:00am

Ja, aber die Linuxdistributionen haben noch nicht RPM-pakete dafür fertiggstellt.


By Fredrik Edemar at Tue, 2004/03/09 - 6:00am

SuSE has a -nds package in their noarch directory.


By Micha at Wed, 2004/03/10 - 6:00am

JA, nau ju benn thenking die distributionen vid Linus Torvalds! ;)


By Frowlen Dietc at Wed, 2004/03/10 - 6:00am

A lot of work still has be be done. More active support for the low saxon project is very much needed.

Projekt Mantainer is Heiko Evermann:
http://i18n.kde.org/teams/index.php?a=i&t=nds

Plattdüütsch wikipedia:http://nds.wikipedia.org

A plattdüütsch localisation will make it easier to sell KDE to the fedetral states. Perhaps we can ask the government in the question hour why they want to introduce win2000 in schools while low saxon was not supported. German federal states hold a poor performance in the support of the European Language charter, however it is there and shall be used.


By Gerd at Wed, 2004/03/10 - 6:00am

Hi,
If you have been experiencing slowdowns with PHP in Quanta you will want to upgrade. There was a bug that slipped through in 3.2 that selectively caused real problems parsing some PHP documents yet was fine with our test cases. We actually had to do a small parser reorganization and some heavy testing. (Thanks testers!)

Also if you were disappointed with VPL it is not perfected yet in 3.2.1 but some bugs and annoying behavior was fixed so it's more usable.

Enjoy!


By Eric Laffoon at Tue, 2004/03/09 - 6:00am

Nice to see that Suse is still offering only a slow quanta 3.2.0 version within their kde-3.2.1 folder. :-(


By Hans Chen at Wed, 2004/03/10 - 6:00am

Sorry to hear that. To paraphrase the old movie... "Use the source Luke" ;-)


By Eric Laffoon at Thu, 2004/03/11 - 6:00am

Thanks for pointing that out. The slowdowns were bothering me quite some time. I actually gave up and switched to kate for php development. Emerging Quanta at moment... can't wait to switch back :)


By Chris van de Wouw at Thu, 2004/03/11 - 6:00am

... i think not

/me gloats about 3.2.1 being in sid for roughly a week already ;P


By AC at Tue, 2004/03/09 - 6:00am

The latest KDevelop I could find for Debian was 2.1.5
http://packages.debian.org/unstable/kde/kdevelop

That one is one year old ;P


By Amilcar Lucas at Tue, 2004/03/09 - 6:00am


By noxis at Wed, 2004/03/10 - 6:00am

But it's really behind with 3.0.1 and not 3.0.2.


By Anonymous at Wed, 2004/03/10 - 6:00am

That is because you are looking at the wrong package. :)

http://packages.debian.org/unstable/kde/kdevelop3


By kosh at Wed, 2004/03/10 - 6:00am

Ok, KDE 3.2.1 is out, but the KDE website has STILL not updated the screenshots for KDE 3.2.0

http://www.kde.org/screenshots/

PS: Still not able to install RPMs for KDE 3.2 because of dependency hell in Fedora Core 1 (grrr...) - The instructions here don't work:

http://fedoranews.org/krishnan/tutorial/kde3.2/

Mind you I haven't bothered to learn how to compile anything! I've read snippits that IBM _may_ be focusing on Desktop development. Maybe the dependency hell will die!

There has got to be an easier way!


By micio at Tue, 2004/03/09 - 6:00am

"Mind you I haven't bothered to learn how to compile anything! I've read snippits that IBM _may_ be focusing on Desktop development. Maybe the dependency hell will die!

There has got to be an easier way!"

You don't have to learn to compile. Gentoo will compile everything for you and say good bye to rpm and dependency hell. :) Debian is also a good distro!

Gentoo! 3 of 16 packages done...


By AM at Wed, 2004/03/10 - 6:00am

Gentoo is realy fine. But I had to wait like 19h for each new kde version to compile... not to mention xfree86, or any other big package.

I didn't have *any* problem installing kde 3.2 on Fedora Core 1.


By Marcos Tolentino at Wed, 2004/03/10 - 6:00am

Where can I download Gentoo? also does it compile itself at install time? and once I get it installed, how can I make it compile KDE 3.2.1? Sorry if they are stupid questions.

LP


By Version4 at Wed, 2004/03/10 - 6:00am

> Where can I download Gentoo?

Have a look at http://www.gentoo.org

> also does it compile itself at install time?

The base installation is binary to get you started.
For the rest you can choose whether you want to compile everything
or use binary packages (though I haven't tried this option).

> and once I get it installed, how can I make it compile KDE 3.2.1?

It's just another package of software... using the "emerge" command
- emerge sync (to get you an up-to-date package list)
- emerge kde
- wait typically 12 to 24 hours :-)
- If all goes well: Launch KDE.


By cm at Wed, 2004/03/10 - 6:00am

Don't Zealot, down!

You are right, you don't have to learn to compile. It's called use apt or yum and find a decent repository. So no, you don't have to have dependency hell either with other distributions.

Gentoo is a good distribution, for its own reasons. But don't start up your FUD machine this early in the morning (for me, at least).


By Jay at Wed, 2004/03/10 - 6:00am

Is there anyone distributing Gentoo's entire portage library on CD-ROM? Some of us are still stuck with dial-up service. Or does the dual-disc version sold at store.gentoo.org contain most of the really big packages? I don't mind downloading smaller apps and utilities, especially if the portage system can recover from lost connections.


By Tukla Ratte at Thu, 2004/03/11 - 6:00am

I'll have some screenshots of MDK 10 soon, that could be used.


By Alex at Wed, 2004/03/10 - 6:00am

Screenshots should show an unmodified KDE with default style.


By Anonymous at Wed, 2004/03/10 - 6:00am

"Ok, KDE 3.2.1 is out, but the KDE website has STILL not updated the screenshots for KDE 3.2.0

http://www.kde.org/screenshots/"

Why don't you make some screenshots with the default style and color, put the images on an accessible webspace and send the link to kde-www@kde.org? I'm pretty sure your offer won't be turned down.


By Christian Loose at Wed, 2004/03/10 - 6:00am

I had no trouble installing on Fedora Core 1. Be sure to use either yum or apt4rpm or handle dependencies for you.


By KB at Wed, 2004/03/10 - 6:00am

have you tried using apt to resolve the dependencies?
I had to do for example
apt-cache search libpq
to find out that I needed postgresql-libs
then apt-get install postgresql-libs


By Ariel Arjona at Wed, 2004/03/10 - 6:00am

Hello, Mc Fly!

Derpendency Hell has been a thing of the past for a good few years now.

urpmi
apt
portage
yum

Shall I go on?

If you USE the system the way it was intended, it'll WORK the way it was intended.


By Xanadu at Wed, 2004/03/10 - 6:00am

...and ports...


By David Johnson at Wed, 2004/03/10 - 6:00am

Yes, and ports. Sorry about that...


By Xanadu at Wed, 2004/03/10 - 6:00am

FYI, you can get nice yum/apt-able packages from http://kde-redhat.sf.net/

-- Rex


By Rex Dieter at Wed, 2004/03/10 - 6:00am

Hopefully Lindows and SuSE will include 3.2.1 (NOT 3.2.0 which hard too many rough spots) and Qt 3.3.2 after the fixed font bug is fixed. Qt 3.3.2 should come out in 2 weeks, right?


By Alex at Wed, 2004/03/10 - 6:00am

> Qt 3.3.2 should come out in 2 weeks, right?

Why? Distributors are able to patch Qt 3.3.1 themselves.


By Anonymous at Wed, 2004/03/10 - 6:00am

Which bug? Could you help me pointing somewhere such bug is reported?

I'm asking 'cause since compiled Qt 3.3.1, only a small subset of all the installed fonts are used by Qt, and the apps look a bit strange around fonts.


By wwp at Wed, 2004/03/10 - 6:00am


By Christian Loose at Wed, 2004/03/10 - 6:00am

Wow, great :-)

Thanks a lot!


By wwp at Thu, 2004/03/11 - 6:00am

Pages