JUL
3
2002

KDE 3.0.2: Second KDE 3 Service Release Ships

The KDE Project today announced the availability of KDE 3.0.2,
the second maintenance release
of the KDE 3.0 series. Dirk Mueller,
the KDE 3 release coordinator, explained that
"a number of stability and useability enhancements have been
backported from the active KDE 3.1 branch to the KDE 3.0 codebase and
bundled in this update. We recommend that all KDE 3 users update
to this newest, stable release.
" More details are in the
announcement,
or jump directly to the download directory.
Congratulations to the KDE developers on another great release! And stay tuned:
the first KDE 3.1 alpha release, this one complete with a slew
of cool new features (such as the widely requested tabbed browsing
in Konqueror), is due out next week already!

Comments

title tells it all.


By abemud at Wed, 2002/07/03 - 5:00am

Yes, go KDE!, but what's with the hostility to Red Hat?


By Navindra Umanee at Wed, 2002/07/03 - 5:00am

why does red hat suck specifically?

I don't use red hat, I am a Mandrake user.

Is it red hat's relative lack of support for KDE? or is it somthing else?


By L.D. at Wed, 2002/07/03 - 5:00am

I use RedHat, and I like it. And I use KDE on RedHat, which means I have to put up with a lot of shit from RedHat people AND KDE people.

But basically, the deal is that RedHat never releases updated KDE updates. What you get on the CD is what you're stuck with until the next full RedHat release. They prioritize Gnome over KDE, which is a perfectly valid^H^H^H^H^H interesting choice.

I like their other decisions though. They're conservative on the right things and cutting edge on the right things, as far as I'm concerned. But it's a pain to be a RedHat KDE user.


By ac at Wed, 2002/07/03 - 5:00am

That's true, I only know one single developer working on KDE at Red Hat. :( He obviously can't do everything but I think we can safely applaud him for trying. Red Hat has tons of G developers on the other hand...

How can we convince Red Hat to devote more resources to KDE? Any ideas?


By Navindra Umanee at Wed, 2002/07/03 - 5:00am

Yes, I love Bero too and shower him with kisses from abroad.

The best way to get RedHat to devote resources to KDE is to just be a better desktop environment. KDE is great but it isn't perfect yet. Well, I haven't downloaded 3.0.2 yet...maybe I'm wrong ;-)


By ac at Wed, 2002/07/03 - 5:00am

I don't think good has anything to do with it, unfortunately. KDE has been comparing favourably to the competition for a long time now, yet Red Hat hasn't bulged in the slightest.


By Navindra Umanee at Wed, 2002/07/03 - 5:00am

It can't just compare though - it has to be flat out, hands-down better. People invest much time learning the ins and outs of their desktop environment, and how to be productive in it.

I've tried frequently to switch from GNOME to KDE, but I can't. Not because one is better than the other (To wit - KDE may be 'better' than GNOME). But because KDE doesn't work quite the way I want it to. And I'm very picky..:)


By gengis at Wed, 2002/07/03 - 5:00am

If you're so picky and so happy with GNOME1, I'm sure you'll be pulling your hair out with GNOME2, eh!


By Navindra Umanee at Wed, 2002/07/03 - 5:00am

I agree completely. I have considered switching to other distributions (usually Mandrake or Debian, depending on the time of day:), but I think I will stick with RedHat, despite KDE pains. Why? A few reasons:
a) I like a number of their choices in what software they choose, apart from preferring GNOME to KDE :(
b) Most proprietary software for linux comes pre-compiled for RedHat, so I know I can run things that don't provide source.
c) A fair amount of open-source software is also precompiled on RedHat.
d) The lure of Debian's apt-get is reduced by the fact that I now have apt-get for rpm, and combined with the Freshrpms tree and various others, apt-get can get me pretty much anything I need.
e) The hassle of switching, when I have already built custom scripts for various things on my system, frankly isn't worth it.
That last point basically boils down to "I'm used to it, and I don't feel like learning the quirks of a new system just yet"
Anyway, the lack of KDE RedHat rpms is quite annoying.


By Matthew Kay at Wed, 2002/07/03 - 5:00am

With b), c) and e) you should have no problem with Mankdrake as it's perhaps the most RedHat-compatible distribution out there.


By Anonymous at Wed, 2002/07/03 - 5:00am

Same goes for SuSE - I switched to it over Mandrake because SuSE offered RPMs faster for more packages, and were more bug free. Specifically the KDE 2.x series of RPMs. Before I switched, I even tried using Cooker. SuSE just seemed better at the time (and still does, but I haven't used Mandrake for about a year).

I've never run into problems installing RH rpms on a SuSE system, either.

--
Evan


By Evan "JabberWok... at Wed, 2002/07/03 - 5:00am

"I have considered switching to other distributions (usually Mandrake or Debian, depending on the time of day:)"

Steer clear of Debian. They aren't actually cutting edge when it comes to KDE. I run KDE unstable. And guess what? It still doesn't have KDE3! How many months has it been already? Same thing goes for Xfree 4.2.

Well, I have already made up my mind. I'll be moving to Gentoo in not so distant future.


By Janne at Wed, 2002/07/03 - 5:00am

gentoo is fantastic! as a former debian fanatic, after installing gentoo, I never looked back. I'm happy now that debian unstable didn't get kde3 for such a long time, or else I'd never have tried gentoo :-) it still hasn't got as many packages as debian, but it's groing ever more rapidly.. I love it that you get to choose yourself what you want, not just from a selection that is called 'unstable.' I just 'emerged' kde 3.0.2, although the default is still at 3.0.1. you just have to 'unmask' kde 3.0.2 and it's the new default. you have to love the ability to chose :-) the gentoo kernel sources are also great.. preemptible, low-latency patches.. :-P and of course, compiling everything from source is 'the-only-way' ;-)) pim zou het zo gewild hebben.


By mark dufour at Wed, 2002/07/03 - 5:00am

Gentoo is great. It compiles everything from source including KDE, so it runs quick optimised on my machine. It will automatically upgrade your software overnight if you ask it to. The only reason I came to this site to check the 3.02 changelog was because I noticed I was running 3.02 this afternoon. Gentoo takes a long time to install, but once installed you never have to worry about keeping your system updated again.

Phillip.


By Phillip at Wed, 2002/07/03 - 5:00am

Gentoo would be great if you could get a DVD/CDRs of the complete distro - its currently unusable unless you've got an xDSL link. Gentoo on a 56K takes days to download :(

Hopefully someone at Gentoo or a kindly Linux redistributor will see the light and sort something out one day - its a hell of a lot quicker to update if you can initially build from a local copy!


By Richard Moore at Wed, 2002/07/03 - 5:00am

See the 6/14/2002 post here: http://www.gentoo.org/, entitled "Gentoo Linux T-shirts, caps, mugs and CDS. Oh, my!"


By Bill at Thu, 2002/07/04 - 5:00am

The Debian KDE maintainer has 3.02 packages (those were available over a week ago), that are apt-gettable (see http://calc.cx/kde.txt for apt-lines). It pays to pop in to the debian-kde list every once in a while:-)


By cobaco at Wed, 2002/07/03 - 5:00am

So where is Xfree 4.2? Where are OFFICIAL KDE-debs? they have had MONTHS to get the packages in the official unstable-tree!


By Janne at Wed, 2002/07/03 - 5:00am

If I remember correctly, the debs won't be uploaded to unstable till after the gcc 3.1.x transition,
see http://lists.debian.org/debian-kde/2002/debian-kde-200206/msg00072.html for the message from the maintainer explaining this.

As for official kde-debs, these debs are from the debian kde maintainer, and these debs are the ones that will go into unstable, once the gcc 3.1. transition is made. That's about as official as it gets.

As for Xfree, debian has to port Xfree to several architectures, work on 4.2. has started (see http://www.debianplanet.org/article.php?sid=696&mode=thread&order=0&thold=0 for more info), they should work fine on i386, but still need lots of work for the architectures not supported by Xfree while supported by Debian.


By cobaco at Wed, 2002/07/03 - 5:00am

As for XFree. Branden Robinson (head of the official Debian X-Strike force) said once,
that the debian packages are the source for every port ot other than i386 architectures.
On the last Linux Tag in Karlsruhe one of the XFree people said that as well.
So that why it takes longer for debian, if you have to have it stable on more than one
arch it takes some time to get it out. Redhat, SuSe and all the others have quite a nice
job here, only i386 (and maybe a bit of Sparc) and thats it. Debian runs on i386, ppc,
arm, sparc, ultrasparc, mpis, mips-el, 68k, my washing machine and my microwave oven.
So it sometimes takes a bit longer.

Quams (Who is using debian since 5 years in an production environment nad is often
quite happy that some things take their time ...)


By Quams at Thu, 2002/07/04 - 5:00am

hi,

please go to http://people.debian.org/branden
there are experimental pre-release of XFree86 4.2.0 Debian packages available for
i386, M68K, big-endian MIPS, IA-64, HP-PA and PowerPC.

i run woddy on an athlon, put the deb-src line in /etc/apt/sources.list
and compiled the packages from source optimized for my athlon (*), without any problems.

apt-get install pentium-builder
export DEBIAN_BUILDARCH=i686
apt-get -b source xfree86

Thanks, ISHIKAWA-san! Thanks, Branden. Thank you all, GNU/Debian!

(*) or at least for pentiumII, athlon-optimized code is only avaible in gcc3.0


By Holger at Thu, 2002/07/04 - 5:00am

How about you stop flaming and engage your brain before your tongue? Look at http://www.debianplanet.org; KDE packages have been available since 3.0.1 publicly (previously the packages were unofficial, and only if you knew where to find them, which involved asking the maintainer), and XFree86 4.2 packages are available.

You, sir, are an idiot.


By Debian user at Fri, 2002/07/05 - 5:00am

So, where are the official packages? Why aren't those packages in Sid? I have known that there are KDE3-debs floating in the net, but why aren't they in Sid?

"You, sir, are an idiot."

Thank you, I love you too.


By Janne at Fri, 2002/07/05 - 5:00am

Hmm, the maintainers seem to be very busy with the release of woody at the moment... that's why some things take more time at the moment.

--

Stephan


By Stephan Hachinger at Fri, 2002/07/05 - 5:00am

if there is somebody who tries to help accomplishing a task / helping others (as for the debian maintainers, who offer their freetime working on that unpaid) and "give the other users a helping hand" some people tend to be unthankful idiots who try to rip the arm.

If it takes too much time for you, Janne, choose an commercial package like redhat, then you can ask them what they did with your money.

Yours,

LMH


By lmh at Wed, 2002/11/27 - 6:00am

If you paid any attention to RedHat, they take a stance very simmilar to Sun and other major for-profit *nix vendors. The only release updates if there is a damned good reason (i.e., a bug/security fix). The latest OpenSSH vunerability is a good example. They did not release the fixed OpenSSH 3.4 to RedHat Network (and their FTP site). They back ported it to OpenSSH 3.1p1 (this is RedHat 7.3). They take great pains to ensure that customers can depend on a very stable, bug/security vulnerabilty free server. They have not (and likely won't) release GNOME2 updates, either. Now you may be able to install GNOME2 out of RawHide, but that is at your own risk. The same appies to KDE.


By forehead at Wed, 2002/07/03 - 5:00am

> The only release updates if there is a damned good reason (i.e., a bug/security fix).

http://www.kde.org/info/3.0.1.html lists security problems, so RedHat should release updates.


By Anonymous at Wed, 2002/07/03 - 5:00am

Ah well,

don't blame Bero or RedHat...they do quite nice work.
Bero is the only one who packages kde rpms for redhat...but this is not his main work.
after all, kde is not the default desktop for RH...it's gnome.
But, why not building kde rpms for rh7.3 by yourself ? it's quite easy and sometimes more stable than the rh provided rpms...

\sh


By Shermann at Wed, 2002/07/03 - 5:00am

> after all, kde is not the default desktop for RH...it's gnome.

no, i think the default attitude towards desktop from RH is yelling around "Linux is not ready for the desktop", as their CEO did, and as they're server-oriented business...

The truth is:
"Linux is ready for the desktop, RedHat is not"


By loopkin at Wed, 2002/07/03 - 5:00am

loopkin,

what Matthew say is not the truth of the world.
In general, Unix was ready for the desktop since Emacs was born ,-)
Linux was ready for the desktop, since StarDivision decides to port StarOffice to Linux.
The problem is, we don't have a real lobby.
It's right, that RH is server-oriented, 'cause there is much more money to make in the moment.
But believe me, in one or two years Linux will come to the desktop (I hope we have then translucent support under X ;))) with a thunderstrike...believe me


By Shermann at Wed, 2002/07/03 - 5:00am

The truth is:
"Linux is ready for the desktop, RedHat is not"

You'll be surprised how many people still think that Linux is not ready for the desktop.
Their arguments:
- None (simply claim that Linux isn't ready for the desktop).
- Too hard to learn and configure ("WHAT? I have to use obscure Unix commands like xf86cfg?"?).
- Too hard to install software ("Don't you get it? I shouldn't HAVE to type in ./configure!!!!", or "Yes, I spent a whole day just to figure out how to install an RPM!")
- XP blows GNOME and KDE away.
- "Linux is currently at a state where Windows 3.1 was."


By Stof at Sat, 2002/07/06 - 5:00am

I've also heard:

-desktop environments crash too much
-poor support for new hardware
-lack of third party applications
-lack of fully featured web browser
-relearning shortcuts, tricks, etc. makes switching difficult
-poor cut and paste support
-lack of integration of applications
-Windows XP is much prettier


By Raymond at Tue, 2002/07/09 - 5:00am

"after all, kde is not the default desktop for RH...it's gnome."

Not on my install of RH, it isn't!

(I only installed GNOME to get at the libraries that various applications require.)


By Paul Boddie at Wed, 2002/07/03 - 5:00am

No you didn't understand me.
Default Desktop of RH is gnome, cause they provide to the GNOME community some coders. Same applies to Sun.

So Gnome is supported better then gnome at RH

\sh


By Shermann at Wed, 2002/07/03 - 5:00am

I'd like to compile myself, but RH usually applies quite a few patches to kde.
Are you compiling from srpm, or from .tar? What config switches do you use?
I'm running RH7.3.


By nbecker at Wed, 2002/07/03 - 5:00am

if you want, i can send you my spec files for it.

regards,

\sh


By Shermann at Wed, 2002/07/03 - 5:00am

> But basically, the deal is that RedHat never releases updated KDE updates.

Haven't you been to http://www.RPMfind.net?

My RedHat 7.3 system, which came with KDE 3.0.0, is now running KDE 3.0.1 thanks to RedHat's update site. Just do a search for kdelibs or whatever package you need, and you'll find official RedHat versions for them.

There is currently a 3.0.2 version of all the KDE packages, but they're CVS snapshots. I'd expect the final versions to be available within a few days.

Trevor


By Trevor at Wed, 2002/07/03 - 5:00am

I suspect that you are referring to the "Rawhide" RPMS. These aren't official in anyway

From the rawhide README:

-------------------------------------------------------------------

Raw Hide Can Be a Bit Tough to Chew on So Run at Your Own Risk (and Enjoyment)

These releases have not been quality tested by Red Hat's Quality Assurance
team. They may not boot. If they boot, they may not install. If they install,
they may not do anything other then waste CPU cycles. If anything breaks,
you most assuredly own the many fragments which will be littered across your
floor.

It may not be possible to upgrade from Red Hat to Raw Hide, from Raw Hide
to Red Hat, or from Raw Hide to Raw Hide! If a stable upgrade path is
important to you, please do not use Raw Hide.

DO NOT USE THESE RELEASES FOR ANY WORK WHERE YOU CARE ABOUT YOUR APPLICATION
RUNNING, THE ACCURACY OF YOUR DATA, THE INTEGRITY OF YOUR NETWORK, OR ANY
OTHER PURPOSE FOR WHICH A RESPONSIBLE HUMAN WOULD USE A COMPUTER. (But then
again what would be the fun of hacking Linux if there wasn't some risk
involved. ;-)....)
-------------------------------------------------------------------

It is probably "safer" to download the Raw Hide SRPMS and do rpm --rebuild to make sure that it is linked with the libraries that you already have on your system - in this way you will minimize any dependencies that you might otherwise have on the unstable rawhide stuff.


By Corba the Geek at Wed, 2002/07/03 - 5:00am

Okay, so I guess "official" is too strong a word. Perhaps "official pre-releases"? "Official betas"?

Anyway, my point was that packages are available, and compiling from the source isn't the only option for RedHat users. While the RawHide packages are not intended to be a continuous upgrade cycle, they're quite useful for updating critical packages between releases. For instance, I used them to upgrade from KDE 3.0.0 to 3.0.1 and never had a single problem.

You say that the RawHide packages have not been tested, and that's true. But none of the other vendors' packages have been tested either. How could they be, since KDE 3.0.2 just came out yesterday?

Trevor


By Trevor at Wed, 2002/07/03 - 5:00am

We release to vendors before users (and the branch is always available from cvs) so testing can occur before the release. We use the time delay as a final test in case anything got missed.

Rich.


By Richard Moore at Wed, 2002/07/03 - 5:00am

So correct me if I'm wrong, but the rawhide KDE RPMS are compiled with GCC 3.1, which is binary-incompatible with GCC 2.x used for RedHat 7.3.

So does that mean I'd have to recompile the whole RedHat 7.3 distro from source using the GCC 3.1 compiler in order not to have compatibility problems with the rawhide RPMS?

If so, I hardly see how having to recompile your distro from source rates as anywhere near as easy as downloading an RPM, which is all you have to do for Mandrake or SuSE.


By ac at Wed, 2002/07/03 - 5:00am

The latest KDE RPMs are for GCC 3.1, but it's not a major problem. You just have to make sure that two libstdc++ RPMs are installed: one with the 2.96 libraries and the other with the 3.1 libraries. The 2.96 works with your 7.3 distro, and the 3.1 works with any new stuff you've got.

This is nothing new. Consider what RedHat has done with the Qt library. I can run Qt programs compiled for Qt 2.x as well as Qt 3.x, since I have both the qt and qt2 packages installed. Having two packages makes a lot of sense because otherwise I'd have to recompile everything I had linked to Qt 2.x after upgrading to Qt 3.x.

There are other examples: python and python2, for instance. RedHat seems to go to a lot of trouble to provide legacy packages that allow old programs to work without recompiling, so I really don't know where all this RedHat-bashing is coming from.

Trevor


By Trevor at Thu, 2002/07/04 - 5:00am

i've actually got a working 3.0.2 distro (read post below), but i went through and first did what you're doing w/ both libstdc++ packages installed, and it wouldn't work. then i went through and upgraded libstdc++, glibc, gcc, and much more to the new rawhide versions, also grabbing all the compat- packages so stuff kept working. even then i still got 'libDCOP.so.4: undefined symbol "some reasonable symbol w/ garbage on the end"' when running apps.

at this point, i don't really care, it works, but however you found to get it working doesn't seem to work for everyone. your points about having multiple versions of packages installed is true, but in this case it seems to have not been done correctly.


By john at Fri, 2002/07/05 - 5:00am

At the very least, you'd have to update FAM. Having libraries in memory that link to different version of libstdc++ is a very bad idea.


By Sad Eagle at Sat, 2002/07/06 - 5:00am

how did you manage this? i've been trying to get the rawhide kde3.0.1 packages to run, and they keep on puking on linker issues (the munged symbol names don't match up).

any clue on how to get around this?


By john at Wed, 2002/07/03 - 5:00am

I think a previous commenter answered this. I presume you're trying to use the binaries. These were compiled using gcc 3.1. They will not work on a 7.x based system without reasonably significant other upgrades


By Rw at Wed, 2002/07/03 - 5:00am

right, i actually did go through the whole process of upgrading to the rawhide libstdc++3, gcc 3.1, glibc, plus all the compat-* pacakges. after much dependency graph walking, i got them all installed, and the kdebase/kdelib 3.0.2 binaries *still* would not run..

grrr... its so irritating..

i'm a long time redhat fan, and this might actually push me from their distro.


By john at Thu, 2002/07/04 - 5:00am

This incompatibility isn't RedHat's fault, although driving their poor users to the extreme of mix-and-matching RPMS is.

When mixing rawhide RPMS into your non-rawhide software, you've got to make sure they're binary compatible versions (check the major revision number: 7.1 and 7.2 are binary compatible, 7.3 and 8.0 are not). The next RedHat will be 8.0, the major version change indicating broken binary compatibility. Don't mix and match major version numbers. It's bad. And if you don't know what the next version number is gonna be? Ask. (Okay, so everyone [including me] though 7.3 was gonna be 8.0. And www.distrowatch.com is calling the next RedHat release 7.4, but I'm right this time. The next RedHat is 8.0)

But the same could be said for any distro. Every development version of every major distro is switching to GCC 3.1 (because it's better) but they're also breaking backwards compatibility at the same time. So don't throw Mandrake development binaries into your current Mandrake box or you'll break it, the same way you just broke RedHat.

Of course, Mandrake users don't have to RESORT to pulling RPMS off their development versions. But that's another story.


By ac at Thu, 2002/07/04 - 5:00am

I'm not sure that the binary compatibility issue is such a big problem. Currently I've got two versions of the libstdc++ package installed: 2.96 and 3.1, and they coexist without any problems that I can see. My RedHat 7.3 programs link with 2.96 and the RawHide ones link to 3.1. There seems to be a pretty clean upgrade path.

Trevor


By Trevor at Thu, 2002/07/04 - 5:00am

Pages