FEB
3
2004

KDE 3.2 Released

Today the KDE Project released KDE 3.2. It is the result of a combined year-long effort by hundreds of individuals and corporations from around the globe. For packages, please visit the KDE 3.2 info page. At the moment binary packages for Conectiva Linux, Slackware (9.0, 9.1) and SUSE Linux (8.2, 9.0) are listed. Or compile the source either manually or with the help of Konstruct after reading the KDE 3.2 Requirements list. All changes can be found in the detailed KDE 3.2 change log or continue to read about the highlights.

Some of the highlights in KDE 3.2 at a glance:

  • Increased performance and standards compliance
    • Lowered start up times for applications and hundreds of optimizations
      make KDE 3.2 the fastest KDE ever!
    • Working in concert with Apple Computer Inc.'s Safari web browser team,
      KDE's web support has seen huge performance boosts as well as increased
      compliance with widely accepted web standards
    • Increased support for FreeDesktop.org standards in KDE 3.2 strengthens
      interoperability with other Linux and UNIX software.
  • New applications
    • JuK: a jukebox-style music player
    • Kopete: an instant messenger with support for AOL Instant Messenger,
      MSN, Yahoo Messenger, ICQ, Gadu-Gadu, Jabber, IRC, SMS and WinPopup
    • KWallet: providing integrated, secure storage of passwords and web form
      data
    • Kontact: a unified interface that draws KDE's email, calendaring,
      address book, notes and other PIM features together into a familiar
      configuration
    • KGpg: providing an easy-to-use KDE interface to industry-standard
      encryption tools
    • KIG: an interactive geometry program
    • KSVG: a viewer for SVG files
    • KMag, KMouseTool and KMouth: accessibility tools for KDE
    • KGoldRunner: a new riff on a classic game
    • ... and many more!
  • Thousands of incremental improvements and bug fixes
    • During the development of KDE 3.2 nearly 10,000 bug reports were
      processed via the KDE Bug Tracking System
    • Approximately 2,000 feature requests were also processed, with hundreds
      of requested features added to KDE applications and components
    • An improved configuration system that opens the door to new
      installation management possibilities, improved roaming support and
      many improvements to the "KDE Kiosk" environment management system
    • Inline spell checking for web forms and emails
    • Improved email and calendaring support
    • Powerful tabbed interface for the Konqueror file manager and web
      browser
    • Support for Microsoft Windows desktop sharing protocol (RDP)
  • Improved Usability
    • Reduced clutter in many menus and toolbars
    • Many applications, dialogs and control panels reworked for clarity and
      utility
  • Enhanced appearance
    • Plastik, a tastefully understated new look, debuts in KDE 3.2
    • Hundreds of new icons improve the consistency and beauty of KDE
    • Tweaks to the default look including new splash screens, (optionally)
      animated progress bars, styled panels and more!
  • New Tools for Software Developers
    • Comprehensive API documentation extended for 3.2
    • Language bindings for ECMAScript (aka Javascript), Python, Java and
      Ruby
    • New versions of the powerful KDevelop IDE and Quanta web development
      suite
    • Umbrello brings UML modeling for 11 different languages including C++,
      Java, SQL, PHP, Python and Perl to KDE

More information and why you should use KDE 3.2 can be found in the KDE 3.2 announcement.

Comments

Yes... removing the embedded player from the list worked. This still seems to be a major bug. How do I report it?


By Rimmer at Fri, 2004/02/06 - 6:00am

Go in konqueror to menu [help->bug report] Click on the link in the popup dialog and follow the bug wizard on bugs.kde.org

Rinse


By rinse at Fri, 2004/02/06 - 6:00am

I had the same problem with Firefox 0.9 for viewing web pages. Fixed it by choosing the "Use settings for 'application' group" option on the Embedded page. I think this should be the default option so changes made in the Find filename pattern window is the default option.

Hope this helps.


By steve at Fri, 2004/04/30 - 5:00am

Hmmm... I tried downloading some PDF files. Despite telling Konqueror to "Show file in seperate viewer" it continues to show the PDF files using an embedded viewer.

Anyone else have this problem?


By Rimmer at Thu, 2004/02/05 - 6:00am

SOmething I've started noticing - my artsd process chews ~30 - 40% CPU time when any app is using it (such as JuK), and my system load rises past 2. This tends to cause some apps to start responding more slowly. Apart from turning artsd off, is there any fix for this?


By Duncan at Thu, 2004/02/05 - 6:00am

Did you try telling artsd to use ALSA?


By Rimmer at Sun, 2004/02/08 - 6:00am

I've just found that the Fedora RPMS from kde.org don't have ALSA enabled! Pulled down the source rpm and I'm rebuilding kdemultimedia with alsa enabled. Will see what happens.


By Duncan at Sun, 2004/02/08 - 6:00am

Well, rebuilts both arts and kdemultimedia - arts to get alsa, kdemultimedia to get mp3 support. Artsd now chews 1 - 2% of my cpu. Yay!


By Duncan at Sun, 2004/02/08 - 6:00am

The edit-file-type, in context menu (upto 3.1) was really useful, and made the process of associating a file extension with a program very easy.

This feature has been removed in KDE 3.2. Took me quite a while to change the default behavior, searching thru konqi settings.

Is there any easier way to do this ?


By anon at Thu, 2004/02/05 - 6:00am

Select "Properties" in the context menu and click an the wrench icon.


By Anonymous at Thu, 2004/02/05 - 6:00am

Wow! that is almost impossible to figure, unless you already know about it.


By anon at Thu, 2004/02/05 - 6:00am

Believe it or not, those responsible for this think that it is a usability improvement. I hope that if they refuse to change it back that they will at leaset make it possible to configure it to work the old way by editing some '*rc' file.

--
JRT


By James Richard Tyrer at Fri, 2004/02/06 - 6:00am

What where the arguments for putting this under some obscure icon?


By ac at Fri, 2004/02/06 - 6:00am

I have been using KDE since 1.x, and I could not figure this out... at least they could have a text statement in front of the wrench - "configure file type".


By anon at Fri, 2004/02/06 - 6:00am

It's right next to the file "Type" text so I guess it was considered as apparent enough. Probably turning the whole text next to "Type:" into a button would be even more apparent?


By Datschge at Fri, 2004/02/06 - 6:00am

For me the problem is, that in debian it doesn't work, I have no idea what to do with it, as far as I remember I reported it, the only thread with the same problem I found is here:
http://lists.debian.org/debian-kde/2004/06/msg00206.html

Anybody experiencing the same problem i.e. the wrench button doesn't trigger any action?


By Dan Hill at Fri, 2004/08/13 - 5:00am

Just wanted to chip in with a big congrats to the developers of this amazing DE. Since my laptop is a P4 2.0 MHz with 512 MB of RAM, I wasn't expecting to see much improvement in performance since KDE was fast already. Man, was I mistaken! You guys realy know how to optimize. I haven't finished trying out all the new features, and testing the bugs I knew of, but I have a feeling I won't be disappointed. Keep up the great work.

Cheers,

Juan.


By Juan I. Guardia at Thu, 2004/02/05 - 6:00am

I meant P4 2.0 GHz.


By Juan I. Guardia at Thu, 2004/02/05 - 6:00am

I installed thru konstruct - works great, except a minor annoyance that if I start an application from konsole, I see a lot of debug messages.

Any way to get rid of them (without having to recompile the whole thing again) ?

Thx


By anon at Thu, 2004/02/05 - 6:00am

I'm not running 3.2 yet, but I think you can turn them off with the program 'kdebugdialog'.


By AC at Fri, 2004/02/06 - 6:00am

Cool! Thanks a lot :-)


By anon at Fri, 2004/02/06 - 6:00am

Is it possible? Comments?


By tetabiate at Sat, 2004/02/07 - 6:00am

Hello,

i have previously upgraded from 3.15 to 3.2. Now i have a problem when opening device links from the desktop. On click the device is mounted, but konqi doesn't open. Instead the windows emulator wine tries to open the device. I tried to find a configuration to change these wrong association. Does someone know where to change this?

Thanks in advance
Jochen


By Jochen at Sun, 2004/02/08 - 6:00am

Since installing KDE 3.2:

No sound

PixiePlus doesn't remember its last window position

Kate forgets that I had the terminal window open last time, so I have to re-setup my window layout each and every time I open Kate

Konqueror tabs are really unreliable; sometimes I get a tab and sometimes URLs are opened in the current window

Konqueror context menus hide the action items I used to click a lot in a sub-menu, which takes away a LOT of the convenience of using context menus

Default theme is far uglier than the default for 3.1.4

Login dialog hides other desktop choices in a sub-menu, instead of having it right on the login dialog where it used to be

Plus an endless myriad of little annoyances...I think I'm going back to 3.1.4 and will check out a future release of KDE and upgrade when it's actually BETTER than the last version and not worse.


By Sean O'Dell at Mon, 2004/02/09 - 6:00am

> No sound
> Default theme is far uglier than the default for 3.1.4

You obviously have package problems (eg the default theme didn't change). And this will not change unless you report your problems to the creator of your packages.


By Anonymous at Mon, 2004/02/09 - 6:00am

After I've built konstruct using gcc 2.96 on redhat 7.3
under /usr/local/kde32, I set up my env as follows:

export KDEDIRS=/usr/local/kde32/
export KDEHOME=~/.kde
export PATH="$KDEDIRS/bin:$PATH"
export LD_LIBRARY_PATH="$KDEDIRS/lib:$LD_LIBRARY_PATH"

and typed 'startx' to start up kde. Soon I get messages
like "pager failed to start", "kpanel failed to start" and etc.
Looking at the output to 'startx' showed the following:
How can I diagnose this?

XFree86 Version 4.2.0 (Red Hat Linux release: 4.2.0-8) / X Window System
(protocol Version 11, revision 0, vendor release 6600)
Release Date: 23 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.17-0.13smp i686 [ELF]
Build Host: daffy.perf.redhat.com

Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Feb 9 18:41:30 2004
(==) Using config file: "/etc/X11/XF86Config-4"
startkde: Starting up...
Could not open library dcopserver.la: no symbols defined
Could not load library! Trying exec....
kdeinit: Launched DCOPServer, pid = 2979 result = 0
_kde_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
ksplash: Inactive pixmap: /usr/local/kde32/share/apps/ksplash/Themes/Default/spl
ash_inactive_bar.png
ksplash: Active pixmap: /usr/local/kde32/share/apps/ksplash/Themes/Default/spl
ash_active_bar.png
ksplash: Standard theme loaded.
DCOP: register 'anonymous-2979' -> number of clients is now 1
DCOP: unregister 'anonymous-2979'Could not open library klauncher.la: no symbols
defined
Could not load library! Trying exec....
kdeinit: Launched KLauncher, pid = 2994 result = 0
DCOP: register 'klauncher' -> number of clients is now 1
DCOP: unregister 'klauncher'
DCOP: register 'klauncher' -> number of clients is now 1
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
library=krandrinithack.la: No file names krandrinithack.la found in paths.
DCOP: new daemon klauncher
Could not open library kded.la: no symbols defined
Could not load library! Trying exec....
kdeinit: Launched KDED, pid = 2996 result = 0
kdeinit: PID 2995 terminated.
DCOP: register 'kded' -> number of clients is now 1
DCOP: unregister 'kded'
DCOP: register 'kded' -> number of clients is now 1
DCOP: register 'anonymous-2996' -> number of clients is now 2
kio (KDirWatch): Available methods: Stat, FAM
kio (KLauncher): KLauncher: Got kdeinit_exec_wait('kbuildsycoca', ...)
kdeinit: Got EXEC_NEW 'kbuildsycoca' from launcher.
Could not open library kbuildsycoca.la: no symbols defined
Could not load library! Trying exec....
DCOP: register 'anonymous-2976' -> number of clients is now 3
DCOP: 'anonymous-2976' now known as 'ksplash'
kio (KLauncher): kbuildsycoca (pid 2999) up and running.
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
DCOP: register 'kbuildsycoca' -> number of clients is now 4
kbuildsycoca running...
DCOP: register 'anonymous-2999' -> number of clients is now 5
kio (KSycoca): Trying to open ksycoca from /var/tmp/kdecache-cwang/ksycoca
kbuildsycoca: checking file timestamps
kbuildsycoca: timestamps check ok
DCOP: unregister 'anonymous-2999'


By kde user at Tue, 2004/02/10 - 6:00am

Hi,

Try to use KDEDIR instead of KDEDIRS.


By Daniel Alomar i... at Tue, 2004/02/10 - 6:00am

same problem. Also konstruct's documentation
specifically says KDEDIRS, not KDEDIR


By no name at Tue, 2004/02/10 - 6:00am

I had this problem and solve it using KDEDIR instead of KDEDIRS. Sure. Try it.


By Daniel Alomar i... at Wed, 2004/02/11 - 6:00am

Hi,

Anybody could lunch the "designer" from qt? Everytime I try ot fails qith a "segmention fault". Any idea????

Regards


By Daniel Alomar i... at Tue, 2004/02/10 - 6:00am

The idea is to use bugs.kde.org and help to add to the report http://bugs.kde.org/show_bug.cgi?id=73843


By Anonymous at Tue, 2004/02/10 - 6:00am

Hi, where I can I get old versions of konstruct
that builds KDE 3.1.4? I don't have much
luck building KDE 3.2 on a RedHat 7.3 machine
but KDE 3.1.4 worked well for me before
I blew it away.


By no name at Wed, 2004/02/11 - 6:00am

Lookup in the README how to get Konstruct via CVS and replace KDE_3_2_BRANCH with KDE_3_1_BRANCH.


By Anonymous at Wed, 2004/02/11 - 6:00am

Hmmm.. another thing I've noticed since installing KDE 3.2 - kgpg doesn't work in that the applet is missing, and I can't run it from the command line.. no errors.. just nothing shows up.

Also, Licq no longer has an notify icon in the panel anymore. If I close off the main window of licq, it still runs... but my little licq thingie is no longer around like it used to be.

Anyone know why this would be? Installed KDE 3.2 using Fedora rpm's.

Laura


By Laura at Fri, 2004/02/13 - 6:00am

Never mind.. I just realized the upgrade removed the system tray. After adding it back again, everything is fine. Doh!


By Laura at Fri, 2004/02/13 - 6:00am

I built gcc 3.4.1 on my linux development box and tried to build KDE 3.2.3 with it. Doh! There is a bug in that version of gcc which prevents correct compilation of classes which inherit from classes where templates are involved.

I built gcc 3.3.4 and tried again - presto! the compile went through OK.

Sure hope this saves someone the days it has taken me to track this down, after looking in all the wrong places first....sigh!

The gcc 3.4.1 bug showed up when trying to compile libksvgdom_la.all_cc.cc:
***************************************************************************
In file included from ../../ksvg/impl/SVGEcma.h:29,
from ../../ksvg/impl/SVGElementImpl.h:32,
from ../../ksvg/impl/SVGShapeImpl.h:24,
from SVGLength.cc:23,
from libksvgdom_la.all_cc.cc:2:
../../ksvg/ecma/ksvg_lookup.h: In function `bool KSVG::lookupPut(KJS::ExecState*, const KJS::Identifier&, const KJS::Value&, int, const KJS::HashTable*, ThisImp*)':
../../ksvg/ecma/ksvg_lookup.h:214: error: invalid use of undefined type `struct KSVGScriptInterpreter'
../../ksvg/ecma/ksvg_lookup.h:28: error: forward declaration of `struct KSVGScriptInterpreter'
In file included from ../../ksvg/impl/SVGList.h:24,
from ../../ksvg/impl/SVGLengthListImpl.h:26,
from ../../ksvg/impl/SVGAnimatedLengthListImpl.h:24,
from SVGAnimatedLengthList.cc:22,
from libksvgdom_la.all_cc.cc:9:
../../ksvg/ecma/ksvg_bridge.h: In member function `virtual void KSVGRWBridge::put(KJS::ExecState*, const KJS::Identifier&, const KJS::Value&, int)':
../../ksvg/ecma/ksvg_bridge.h:93: error: `m_impl' undeclared (first use this function)
../../ksvg/ecma/ksvg_bridge.h:93: error: (Each undeclared identifier is reported only once for each function it appears in.)
In file included from ../../ksvg/impl/SVGList.h:26,
from ../../ksvg/impl/SVGLengthListImpl.h:26,
from ../../ksvg/impl/SVGAnimatedLengthListImpl.h:24,
from SVGAnimatedLengthList.cc:22,
from libksvgdom_la.all_cc.cc:9:
../../ksvg/impl/ksvg_scriptinterpreter.h: In function `KJS::Object cacheGlobalBridge(KJS::ExecState*, const KJS::Identifier&)':
../../ksvg/impl/ksvg_scriptinterpreter.h:103: error: `Internal' undeclared (first use this function)
In file included from ../../ksvg/impl/SVGLengthListImpl.h:26,
from ../../ksvg/impl/SVGAnimatedLengthListImpl.h:24,
from SVGAnimatedLengthList.cc:22,
from libksvgdom_la.all_cc.cc:9:
../../ksvg/impl/SVGList.h: In copy constructor `KSVG::SVGList::SVGList(const KSVG::SVGList&)':
../../ksvg/impl/SVGList.h:51: error: `other' undeclared (first use this function)
In file included from ../../ksvg/impl/SVGColorProfileElementImpl.h:29,
from SVGColorProfileElement.cc:22,
from libksvgdom_la.all_cc.cc:73:
***************************************************************************


By Doug Hutcheson at Wed, 2004/08/18 - 5:00am

Did you try with gcc 3.4.1 and without --enable-final?


By Anonymous at Wed, 2004/08/18 - 5:00am

Pages