AUG
15
2001

KDE 2.2 Ships (Visit an FTP Server Near You)

After some delay caused by a severe hardware failure on KDE's ftp server,
the KDE Project has announced
the official release of KDE 2.2. This release brings a lot of goodies,
including: faster startup times (using the experimental
objprelink
method
) and performance; numerous improvements to HTML rendering
and JavaScript support; the addition of IMAP support (including SSL and
TLS) to KMail; a new plugin-based print architecture with integrated
filter and page layout capabilities; a number of new plugins for Konqueror
(including a Babelfish translator, an image gallery generator, an HTML
validator and a web archiver); native iCalendar support in KOrganizer; and
a new personalization wizard. Compaq
has also announced the addition of KDE to
Tru64. Time to tell the boss to forget XP, and use KDE (hmmmm, back in my college days that would have made a nice chant: 'Forget XP, use KDE', . . .).

Comments

Is there something that I miss, or why is it that Redhat 7.x i386 packages have no kdebase or kdelibs listed?


By Rithvik at Wed, 2001/08/15 - 5:00am

Maybe because they didn't work?

I downloaded them yesterday and tried to install them this morning. They had several wierd dependencies (incl. fam. Imon patch doesn't work with 2.4.8) that I had to get from rpmfind because they are not in RH7.1

...once installed KDE crashes on startup...

KDE is the WORST thing to install/upgrade (I really like it when it works though)


By blah at Wed, 2001/08/15 - 5:00am

The main problem results from a wrong installed fam. Get the fam package from ftp://ftp.kde.org/pub/kde/contrib. The binary did not work for me, so I tried to rebuild the source which did not work automatically. I had to include a #define NULL 0 in include BTree.h . Also the test directory had to be removed from the Makefile. A working version can be found under http://www.aerie.at/rh71kde .

You will also need to correctly configure xinetd if you are running this daemon ( most likely if you run RH71 ). You will find my fam config file under the location meant above. Just install it under /etc/xinetd.d and restart the daemon. BTW, this I write under KDE2.2. It runs just fine, after installation troubles ;-)

CU Roland


By Roland at Wed, 2001/08/15 - 5:00am

"The binary did not work for me, so I tried to rebuild the source which did not work automatically. I had to include a #define NULL 0 in include BTree.h ."

I think someone forgot to #include, but I'm glad to see you worked it out. :-)

"Also the test directory had to be removed from the Makefile."

I think this is only the case if you do not have imon support in the kernel, but this should not happen. I will see if I can fix it.

Feel free to contact the list (fam@oss.sgi.com) with any problems or feedback.

Thanks.

--
MICHAEL WARDLE
SGI FAM Maintainer


By Michael Wardle at Wed, 2001/08/15 - 5:00am

I use SuSE 7.2, and had no troubles at all installing the rpm's :-)


By Steven at Wed, 2001/08/15 - 5:00am

You mentioned that you used suse 7.2. I downloaded all the rpms from the Suse site (kde support section) under the base packages and I got lots of dependency errors. After much messing about I got it installed but the only problem is I'm getting errors (as a user not a roo) like not being able to access dev/video (perm denied).
Where and how did you get your rpms from ?


By Andy O at Fri, 2001/08/31 - 5:00am

"fam. Imon patch doesn't work with 2.4.8"

The latest Linux version the imon patch has been verified to work on is 2.4.2. I am working on a release for 2.4.6 and 2.4.8, and they should be out very soon.

You will probably notice that fam works without imon support in the kernel, but the performance may be somewhat worse.

If you have any problems, please contact me, or the fam project mailing list fam@oss.sgi.com.

By the way: do you know which component of KDE relies on fam? I understand that fam support had been added to KDirWatch, but I'm not sure that this made it into the release version of KDE.

Thanks.

--
MICHAEL WARDLE
SGI FAM Maintainer


By Michael Wardle at Wed, 2001/08/15 - 5:00am

Will the 2.4.6 patch work with 2.4.7? That's what I run at home and at work, since I've not heard one person that says 2.4.8 is stable.

Jason.


By Jason Tackaberry at Wed, 2001/08/15 - 5:00am

I had a similar problem...I downloaded yesterday and found lots of things missing and crashes on starting KDE. Found out that they did have all of the packages up 'til after 5:00 EST.
I went back and downloaded all of the stuff under the 7.x i386 dir and got everything out of the non-kde dir and it worked fine.


By Steven Gilroy at Wed, 2001/08/15 - 5:00am

Hello folks.

I have successfully installed KDE 2.2 on my RedHat 7.1 system using RPMs. Since many people seem to be having trouble, here is how you should do it.

Note that a very easy way to install KDE 2.2 RPMs is to use --force --nodeps, but that screws your system slightly. What I describe takes longer, but it is clean (mostly).

1. Know your dependencies

Download all the KDE RPMs in one directory.

cd kde_rpms_directory
rpm -Uvh *.rpm

Make a note of all missing packages or files. Then, go to rpmfind.net. Enter the exact name of the missing file or package and download the appropriate package. Always get the RPMs built for RedHat Rawhide (their current development tree).

Here are the packages I personnally had to download:

libfam
openssl
libxml2
libxsltpcre (and pcre-devel, I think)

You might also have to get the following:

libogg
libvorbis

2. Ogg and Vorbis

If you have Ximian Gnome installed, you are in an interesting situation. rpm does not believe these packages to be installed, but they are -- under different, Ximian-chosen names. Just ignore that specific error message.

If you do not have Ximian Gnome, do not ignore the message. Get the RPMs and install them.

3. The openssl problem.

openssl is a special case. If you try to upgrade it, you will be told that many packages need it. That is true. What is also true is that both these libraries can co-exist on a system. Do the following:

rpm -i --test openssl*.rpm

The only error message you will see is that some one file clashes. That file is not the library itself, but an executable binary. This is a file you can safely overwrite with a newer version.

rpm -i --replacefiles openssl*.rpm

Now you have both versions installed.

4. The pcre problem

You will not be able to install the pcre RPMs because they would overwrite files from your already-installed kdesupport RPM. So we will have to remove kdesupport before we install pcre... We will do that later.

5. The other dependencies

The other RPMs I listed do not cause any problems. Install or upgrade them. If you need additional ones (it could happen), get them from RPMfind and install or upgrade them.

6. Uninstalling KDE

Log out and use an old-fashioned tty login to log
on as root. Or switch to another desktop environment and open a root console. Do the following:

rpm -e kdelibs

It will not work. You will get an error message telling you about all the packages that depend on it. Make sure these are just the normal KDE packages (they were for me), and remove them. The, you can remove kdelibs and kdesupport

rpm -e kdemultimedia
rpm -e kdeadmin
rpm -e koffice
...
rpm -e kdelibsrpm -e kdesupport

7. Re-installing KDE

First, install the problematic pcre RPMs we skipped earlier.

rpm -Uvh pcre*.rpm

Finally, you are ready to go.

cd kde_rpms_directory
rpm -Uvh *.rpm

8. More problems?

If you have Ximian gnome installed (like I do), you will have the libogg and libvorbis problem I mentioned earlier. Some multimedia packages will complain about it. Use the "--nodeps" flag. There is not much else you can do.

rpm -i --nodeps kdelibs-sound*.rpm

In my case, I did not install kdebindings-python because I did not want to install Python 2.1. I do not recommend upgrading Python right away unless you are certain you need kdebindings-python.

I have removed koffice and not re-installed it because (a) I do not use it much, (b) want to wait for koffice 1.1, and (c) it depends on kdesupport, which I no longer have. However, if you still want koffice 1.0, do the following:

rpm -i --nodeps koffice*.rpm

The missing kdesupport package annoys rpm but since all kdesupport components have been installed separately, there is no real problem.

9 Enjoy!

I have just started using KDE 2.2. It seems wonderful. Enjoy yourselves, and report those bugs.


By Jerome Loisel at Wed, 2001/08/15 - 5:00am

Hello again,

The package list should have read:

libfam
openssl
libxml2
libxslt
pcre (and pcre-devel, I think)

An important note abour rpm:

kdeadmin will whine about not having rpm 4.0.3. That is because kpackage has been built against it. I do not recommend upgrading rpm. That can be downright dangerous at times (though it shouldn't be in most cases).

Solution: install kdeadmin with "--nodeps" and do not expect kpackage to work properly. That is what I did. I can live with a non-working kpackage, as you can probably tell. :-)

The "Uninstalling KDE" part should have read:

...
rpm -e kdelibs
rpm -e kdesupport

Yes, I think that both these posts sum up why many people prefer Debian now. :-)


By Jerome Loisel at Wed, 2001/08/15 - 5:00am

All I did was download roswell isos, install Roswell, then download all KDE rpms and type rpm-Uvh *.rpm, seemed to work fine for me (except for python-bindings which I simply just did not bother to install)


By C. Stone at Wed, 2001/08/15 - 5:00am

I've also written a short HOWTO for installing the RedHat RPMs, and it has worked for me and a few others. It's not perfect, but as I said, it works for me.

Please note, my solution needs no files from Rawhide, and just uses the files available on the kde ftp site.

The HOWTO is at a href="http://www.athame.co.uk/kde-redhat.html">http://www.athame.co.uk/kde-redhat.html


By Andy Fawcett at Wed, 2001/08/15 - 5:00am

Heh, I love Zope, I really do :)

Sorry for the fscked up URL, you'll just have to cut and paste :)

Andy


By Andy Fawcett at Wed, 2001/08/15 - 5:00am

Visit:

http://rpmfind.net/linux/rawhide/1.0/i386/RedHat/RPMS

to get the latest RH 7.1 updates including rpm 4.0.3, SDL, openssl etc.


By Asif Ali Rizwaan at Wed, 2001/08/15 - 5:00am

Thanks Debian! :)
I see lotsa lesser mortals having
problems with other distros

----
apt-get into it


By ac at Thu, 2001/08/16 - 5:00am

The so called RH7.1 upgrade is NOT for RH7.1 !!
A RedHat 7.1 upgrade of KDE that requires me to first upgrade glibc? What on earth is that. I'll wind up installing RedHat 7.2 beta before i can get this baby going. This is not good. Looking forward to a series of rpm's actually build for RedHat 7.1. Thankyou.


By R.K. at Thu, 2001/08/16 - 5:00am

You're right. Bero (the packager) said on Slashdot that the packages are meant for the upcoming RH7.2. So you can either wait for that, or install new sh-utils and glibc-packages plus all the stuff non-kde directory before trying to install the kde-packages. Even then you will break something minor like gnorpm.

I actually tried to satisfy all the dependencies with the latest Rawhide rpms, but gave up after an our or so of package hunting. Anyway, KDE2.2 works nicely with the rpms I mentioned above.


By Janne S at Fri, 2001/08/17 - 5:00am

I ran into weird problems and decided I'd rebuild everything myself. The results are at http://www.opennms.org/~ben/kde2.2/ (sorry, all I get as an encoding choice is "Plain Text") -- you may need Ximian Gnome installed to meet some of the dependencies (not sure, I already had it installed when I started building -- libxml2 and such may get picky on you). I also made a "kdeliquid" RPM with mosfet's liquid theme engine.

You should be able to pull the whole big directory down and do "rpm -Uvh *.rpm" and it will work just fine (I think -- haven't tried on any other 7.1 boxen).


By Ranger Rick at Fri, 2001/08/17 - 5:00am

Oh well. I've shopped every official RH release till now, cept 7.0. I'll do it again. Looking forward to meet KDE2.2 in RH7.2 then. (Will study the new bootloaded in the meanwhile.)

FWIW: I would have gladly have bought a Ximian'alike CD of KDE for RH7.1, but i guess some serious market research needs doing before the KDE-team jumps that bandwagon.


By R.K. at Sun, 2001/08/19 - 5:00am

doh.. i'm lying - shopped every release since 4.2 that is.


By R.K. at Sun, 2001/08/19 - 5:00am

For all of you who are asking about CUPS/KDEPrint: to quote the really superb (even if incomplete) KDEPrint Handbook:
####

This handbook describes KDEPrint. KDEPrint is [...] an intermediate layer between the KDE (or other) application and the selected (and installed) print subystem of your Operating System...

KDEPrint is not a replacement of the printing subsystem itself. KDEPrint therefore does not provide for the spooling, and it does not do the basic processing of PostScript or other print data....

It should be noted that both the developer of this application, and the author of this document are most familiar with CUPS as a printing system. At the time of writing, CUPS is the best supported printing subsystem, and it is the best documented. This handbook is work in progress, and later versions of the KDEPrint software and editions of this handbook will support and explore more closely other printing systems.

In the meantime, even if your printing subsystem is not yet well covered, you are encouraged to explore the Printing Manager module in KControl, and you will find its operation to hopefully be fairly self evident, no matter what printing subsystem you use.

So it's up to you, not KDE, to install CUPS if it is your favourite. Or tell you distributor to bundle it as default... ;-)


By me-the-cups-fan at Wed, 2001/08/15 - 5:00am

So they decided to do it anyway, any details?


By Yatsu at Wed, 2001/08/15 - 5:00am

It's not contained in the [source code] release. Some packagers/distributors may have applied it to their packages on their own.


By Someone at Wed, 2001/08/15 - 5:00am

ah, thank you.. i forgot KDE only supplied the source code.

..and would anyone know if debian (sid) has this applied in it's kde packages?


By Yatsu at Wed, 2001/08/15 - 5:00am

i think so, altough i did not notice much difference (maybe because my disks have always been the bottleneck)


By ik at Wed, 2001/08/15 - 5:00am

I read on freekde or gui-lords or somewhere that it does, but I haven't had time to upgrade yet.


By Erik Severinghaus at Wed, 2001/08/15 - 5:00am

..and would anyone know if debian (sid) has this applied in it's kde packages?

Yes it does, and on my old 64MB P2-233, it makes all the difference. Konqueror absolutely flies in use now as each embedded KPart loads in milliseconds rather than a second or two. Startup time for Konqui and KMail (the two worst offenders in KDE) are about halved, indeed KMail now appears almost instantly - this on such an old system, despite the 15000+ mailinglist emails lying about.

If you haven't upgraded to the 2.4.8 kernel yet, that comes recommended too, as there are some changes to the VM that make it FAR nicer in interactive use like KDE.

(2.4.8 still goes completely loony if you load it really heavily and are running out of swapspace, but this rarely happens on the desktop - I happily run and work with Konqui, Mozilla, the GIMP, KMail and licq simultaneously without much slowdown - this on a 64MB machine!)

My comparison of speed on this old box has always been against Win98. Whilst Win98 is generally very sucky, it has pretty low overheads and thus runs very fast, especially so on such old slow, memory-light machines.

KDE2.2 running with a 2.4.8 kernel now surpasses Win98 in terms of speed, and of course beats it to a bloody pulp (and has done for a very long time) in terms of stability, beauty and power. Win2k, KDE's real competitor, is bigger, heavier, slower, runs like a slug by comparison. And it's still not as pretty!

Well done KDE team. You've gone from obscure niche to one of the most important desktop GUIs in existence in what... 2, 3 years? - MacOS X and Windows XP are the only others in the same league, IMHO. KDE is the lightest, fastest, most powerful and most configurable of all of them.

Looking forward to KDE3 changing the world some more...


By Amazed of London at Wed, 2001/08/15 - 5:00am

> KMail now appears almost instantly - this on
> such an old system, despite the 15000+
> mailinglist emails lying about.

If you have thousands of messages in say the inbox and sent-mail folders then this speed up is probably primarily due to the rewritten folder code in KMail rather than object prelinking.

To be frank I'm just glad that people have noticed it's faster.

About being 'almost instant', yes there is still room for improvement :-)

Don.


By Don Sanders at Thu, 2001/08/16 - 5:00am

Mandrake 8.0 RPMS comiled with optimizations can be found via http://www.pclinuxonline.com/


By R. Bos at Wed, 2001/08/15 - 5:00am

There seems to be an experimenal directory in the SuSE dirs, it puts stuff in /opt/kde2/lib/i686, is this the prelinked stuff ?


By frido at Wed, 2001/08/15 - 5:00am

Are these patches available somewhere?
Or are they already comitted to CVS?

Thanks


By raph at Thu, 2001/08/16 - 5:00am


By Someone at Thu, 2001/08/16 - 5:00am

This is a bit confusing. The press release seems to indicate that prelinking is available. I does not seem to be.

I installed objprelink and applied the configure-patch but I got some strange errors compiling kdelibs. I'm trying again without it right now.

Anyone compiling themselves who got it to work? Any tricks to it?


By jd at Thu, 2001/08/16 - 5:00am

This is very late....

If you're using a RedHat or Mandrake system, use the kg++ and kgcc compilers. Yes, you've got two compilers on your system. The K compilers are an older and more stable version of GCC, the default version isn't really any good (which is fair enough considering the improvements the GCC team is making IMHO)

I can never remember the right order for these commands - basically
rename gcc gcc.bak
rename cc cc.bak
rename c++ c++.bak
rename g++ g++.bak

Then create symbolic links
gcc -> kgcc
cc -> gcc
g++ -> kg++
c++ -> g++

Despite all that, I never got my KDE to compile - but fortunately pclinuxonline have prelinked i686 RPMs. I have my suspicions about Mandrake 8.0's dev cred.


By Bryan Feeney at Thu, 2001/08/23 - 5:00am

I downloaded kdelibs (KDE_2_2_RELEASE) from CVS.

After running "make -f Makefile.cvs" I got some warnings about "AC_TRY_RUN" which had no default
for the purpose of cross compiling.
I started ./configure ... and got an error.
A test program couldn't execute, because of cross compiling.

Can anybody give me a solution to compile kdelibs properly?


By gjw at Wed, 2001/08/15 - 5:00am

RTFM:

http://www.kde.org/documentation/faq/install.html
http://developer.kde.org/documentation/other/compiling.html

Hope this helps. General hint: add the EXACT error message or nobody can help you but yourself.


By Moritz Moeller-... at Wed, 2001/08/15 - 5:00am

##kdelibs KDE_2_2_RELEASE

#make -f Makefile.cvs

*** Creating configure
configure.in:92: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:757: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:1217: warning: AC_TRY_RUN called without default to allow cross compiling
*** Creating config.h template
configure.in:92: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:757: warning: AC_TRY_RUN called without default to allow cross compiling
configure.in:1217: warning: AC_TRY_RUN called without default to allow cross compiling

#./configure

checking if getaddrinfo works using numeric service with null host... configure: error: can not run test program while cross compiling


By gjw at Wed, 2001/08/15 - 5:00am

Thgese warnings are okay, I got these, too, but the packages compiled anyway. So I don#t know why it fails for you but it#s not because of the warnings.
Maybe you have a cross compiler installed but did not know or want to have it? Try it with a standard gcc...

Greetinx,

Gunter Ohrner


By Gunter Ohrner at Thu, 2001/08/16 - 5:00am

It was a linker problem so that the test programm couldn't be executed.
Something messed up my system (maybe some SuSE rpms).
I reinstalled my SGI RedHat Linux 7.1 XFS
and now everything seems to work fine.

Have a nice weekend and enjoy KDE

G.J.W.


By gjw at Sat, 2001/08/18 - 5:00am

> RTFM:
>
> http://www.kde.org/documentation/faq/install.html
> http://developer.kde.org/documentation/other/compiling.html

This didn't help and I read them before.

What about the packagers?
Maybe they had the same problem?


By gjw at Thu, 2001/08/16 - 5:00am

Hi !

KDE 2.2 fails to install on a Redhat 7.1, due
to dependency errors :

librpm-4.0.3.so is needed by kdeadmin-2.2-1
librpmbuild-4.0.3.so is needed by kdeadmin-2.2-1
librpmdb-4.0.3.so is needed by kdeadmin-2.2-1
librpmio-4.0.3.so is needed by kdeadmin-2.2-1
libcrypto.so.2 is needed by kdebase-2.2-1
libssl.so.2 is needed by kdebase-2.2-1
python2 >= 2.1 is needed by kdebindings-python-2.2-1
kdesupport is needed by koffice-2.0.1-2

I rebuild rpm-4.0.3-0.88.src.rpm but then I got
a lot of other dependency errors when trying to install it.

What does this mean ? Many hours of work in order to upgrade 90 % of the system ?
Martin.


By Martin Andersen at Wed, 2001/08/15 - 5:00am

I fear yes. I've rant about this in previous article, so I don't want to repeat myself.

I've just build new openssl package, but the system refuses to upgrate it, because plenty of packages depend on libssl.so.1.

I always get a strange taste in my mouth when my only choice seems to be --nodeps or --force.


By Marko Samastur at Wed, 2001/08/15 - 5:00am

To install kde2.2 , you will need some extra packages. Download binaries from rpmfind.net. In case of dependency problem about libssl and libcrypto, just put a symbolic link of lib*.so.2 to lib*.so.1 . Thats' it. I got it working within 5 minutes ! yes, dont't upgrade packages independently but upgrade them simultaneously with command like "rpm -Uvh *" . Otherwise you will be in trouble .


By vk at Wed, 2001/08/15 - 5:00am

I've always liked dependencies in GNOME. It required about forty upgrades before it started. It seems that KDE finally reached this level - bravo KDE guys, we beat those GNOMES once again ! Look at those posts - the newest KDE packages won't run on SUSE, Mandrake, RedHat, Caldera ( not mention FreeBSD's or Sun's ). SUSE users must --force --nodeps all RPMS, but it seems that RH users are recommended to change glibc !. The next release probably will run seamlessly only on Microsoft Windows !


By Bee at Wed, 2001/08/15 - 5:00am

Oops.

My KDE 2.2 on SuSE 7.2 seems to be a hallucination. And I installed via

rpm -Uvh *.rpm

Perhaps it makes a difference to use the "official" SuSE binaries from the *SuSE* server?


By Anonymous at Wed, 2001/08/15 - 5:00am

I'm glad to hear that it worked on Suse, but I have RedHat and I'm surely not going to change my glibc., so I have to wait. It is probably Suse itself, which provides those packages and I hope RedHat will also provide its packages in a few weeks. We'll see.


By Bee at Thu, 2001/08/16 - 5:00am

Correct me if I am wrong,

But KDE don't make the binaries they only give out the source code. So shouldn't you be ranting at RedHat instead of the nice people at KDE?

I am one of those strange people that likes to compile from source. And I have had no problems so far (Only done libs and base).

Feel free to shoot me I'm having a bad week at work anyway :)

Royce


By Royce at Thu, 2001/08/16 - 5:00am

RedHat has backwards-compatibility rpms called "openssl095" and such -- install these (see rpmfind.new or ftp to rawhide.redhat.com/redhat/linux/rawhide/) to satisfy rpms that use the old libraries


By Matthew Kay at Wed, 2001/08/15 - 5:00am

i have no sucess. when i startx, i get the splash screen it says kde is up and running. but i don't get anything 'cept the background. i'm running on suse 7.1 i first downloaded the packages from a suse mirror. i noticed that the mirror was not the same as suse.com. i tried the binaried there. i finally had to run rpm with --nodeps and --force. i kept getting depndency errors for packages that were installed. i don't know what else to do, or what i'm missing. i don't know what else to try at the moment its just been one big frustration. and i can't get the previous version to work either.


By zed aardvark at Thu, 2001/08/16 - 5:00am

Pages