KDE 2.2alpha2 is Out!

KDE 2.2alpha2 is here! Blessed by release master Waldo Bastian only a few hours ago, this release has a ton of improvements over KDE 2.1.x. You can view the ChangeLog or glance at the alpha1 announcement for an overall idea of some of the changes versus the stable branch. However, to discover the rest of the cool stuff -- such as the new regexp filter in KNewsTicker or the Kicker taskbar/extension improvements -- you'll have to download KDE 2.2alpha2 and see for yourself. As usual, source is available as well as binary packages (read our policy) for Mandrake, Red Hat, SuSE and Tru64. Debian users should check the regular sources. Keep in mind that this alpha release is not for people who expect a stable desktop, there is a short list of known problems already.


"The release will be made on or before 11:59PM GMT -8 (Pacific Daylight Time) June 15th, 2001 A.D. Because otherwise I will commit suicide at 12:00 AM on June 16th, and you will all feel very, very bad."

(from http://news.linuxprogramming.com/news_story.php3?ltsn=2001-05-15-001-06-LT)

By Erik at Sat, 2001/06/02 - 5:00am

Compiled kdelibs with no problems, kdebase, however

Entering directory `/home/asr/kdebase-2.2alpha2/libkonq/favicons'
/bin/sh ../../libtool --mode=link --tag=CXX g++ -O2 -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST -o libkded_favicons.la -rpath /u1/kde/lib/kde2 -L/usr/X11R6/lib -L/u1/kde/lib -module -avoid-version favicons.lo favicons_skel.lo libkded_favicons_la_meta_unload.lo -lksycoca
grep: /usr/local/kde/lib/libDCOP.la: No such file or directory
sed: can't read /usr/local/kde/lib/libDCOP.la: No such file or directory
libtool: link: `/usr/local/kde/lib/libDCOP.la' is not a valid libtool archive
make[3]: *** [libkded_favicons.la] Error 1
make[3]: Leaving directory `/home/asr/kdebase-2.2alpha2/libkonq/favicons'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/asr/kdebase-2.2alpha2/libkonq'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/asr/kdebase-2.2alpha2'
make: *** [all-recursive-am] Error 2

I have KDEDIR set to /u1/kde, I wonder why it keeps looking for libraries under /usr/local/kde??

Any hints?

By AbuSulaiman at Sat, 2001/06/02 - 5:00am

Did you "./configure --prefix=/u1/kde"?

By KDE User at Sat, 2001/06/02 - 5:00am

maybe you forgot to set prefix as well:
./configure --prefix=/u1/kde

Generally, you should try to use standard locations, like /usr/local or /opt/kde for your prefix.

By Arnd Bergmann at Sat, 2001/06/02 - 5:00am

Funny, the moment I changed the prefix from /u1/kde to /usr/local/kde worked fine. Thanks for the pointer.

By AbuSulaiman at Sat, 2001/06/02 - 5:00am

I tried installing it and found that I needed the following libs:
each one of which I had to search for on rpmfind.net. Furthermore some of these had
not yet been compiled for RedHat yet. So I had
to download them for the Polish distribution...

Am I missing something?
Would it have been easier to compiler from source?


By Henry Story at Sat, 2001/06/02 - 5:00am

you can find all of these libraries from the redhat linux development snapshot versio, called rawhide.


By Evandro at Sat, 2001/06/02 - 5:00am


I got it installed. It seems to work fine.
I have not found any nfs problems yet.

This new version is great. Finally I can use kmail, now that it has IMAP functionality! So I won't need Star Office as often, which will save me a lot of RAM.

Konqueror loads a lot faster now too...

Thanks again,


By Henry Story at Sun, 2001/06/03 - 5:00am

I noticed the same on my RH7.1 machine. Rawhide has some of these rpms but they break other things. I have never tried the PLD dist, so I cannot comment on it. On a happy note, 2.2Alpha2 on RH6.2 (compiled) is spiffy.

By ne... at Sat, 2001/06/02 - 5:00am

Installed the Mandrake rpms, and so far things looks good.


1)A website that I use a lot wont work, it is javascript driven and this may have to do with the HTML rendering issues. It has a form that is filled out, and the "send" button is a link to the url "javascript: if(function() && function()) function()" which is repeated twice. This button has to be pressed at least two times. Can it be that KHTML decides that I'm allready there? URL: www.rejseplanen.dk

2) I had the xmms-kde applet installed from rpm for mdk 8 and tried to activate it again after upgrading, which added an empty applet to kicker. This thing couldn't be removed, so I had to manually remove it from kickerrc, and before this to take effect I had to kill kicker and reboot!!!

3) KDM wont work , or at least init 5 fails. I do not know (yet?) if this is the mandrake script or kdm, but I reset my init to 3 and have to manually startx.

4) I added a konsol schema, but it does not appear when I start konsole as a normal user:(( (cool feature though)

Anyway, apart from theese I love it!


By Anders at Sat, 2001/06/02 - 5:00am

I am having the same problem with KDM using Mandrake 8.0. I haven't tried to fix it yet though. If anyone figures anything out, please post a solution.

By typical75 at Sat, 2001/06/02 - 5:00am

I found that before installing 2.2a2 on RedHat 7.1 I had to upgrade a few libraries, including readline, openssl and crypto.

After this, a few apps that required libreadline4.1 wouldn't work... symlinking 4.1 to 4.2 works for some (ftp, telnet), but I still can't get nfs to mount stuff... any word on what the final build will require?


By Darrell Esau at Sat, 2001/06/02 - 5:00am

By Evandro at Sat, 2001/06/02 - 5:00am


I want try Koffice 1.1 beta2, but I always get this error message on application start:

WARNING: found no definition of PluralForm koffice (lib kofficecore): WARNING: kword.desktop: no X-KDE-NativeMimeType entry! koffice (lib kofficecore): ERROR: Couldn't find the native MimeType in kword's desktop file. Check your installation !

And after that, the startup process fail...
It's a clear installation on Mandrake 8.0. RPMs was downloaded from the original kde2.2alpha2 ftp site.

Can anyone help me?


PS: but alpha2 is a great release, I love it! Konqueror is amazing, wonderful, awesome....

By NÉMETH Balázs at Sat, 2001/06/02 - 5:00am

I had a similar problem when I first installed KOffice under KDE2.1.2
From reading bug reports, others have too, so the problem seems to be a regular (if intermittent) one. For some reason, the System Configuration Cache (SyCoCa) doesn't seem to like some KOffice configuration files (I don't know if it applies to other conf files as well). You can try running 'kbuildsycoca' from the command line (it's in $KDEDIR/bin). This will manually rebuild sycoca. If that doesn't make your KOffice apps work, edit and save the appropriate config files so that they get new dates (don't actually change anything). This should make sycoca reparse the files. If you're not comfortable with editing files, just type these 2 lines at the command line:

cp xyz.desktop xyz.desktop.save
cp xyz.desktop.save xyz.desktop

This will simply make a copy of the appropriate config file and then copy it back to the original name (giving it a new time stamp). Obviously replace 'xyz' with the appropriate name, e.g. kword.desktop for kword.

Hope this helps :-)
(Still wondering why it happens at all though!)

By Fred at Sat, 2001/06/02 - 5:00am

touch xyz.desktop

By Corba the Geek at Sun, 2001/06/03 - 5:00am

I use gentoo and I had this problem. I deleted /usr/kde/3.5/share/applications/kde/kivio.desktop
and then kivio started working.

By Noah Eltzroth at Thu, 2006/10/19 - 5:00am

I'm a strange person that actually sometimes does read the manuals, so finding that clicking any entry in the kde helpcenter menu would just answer

The requested help file could not be parsed:

was a dissapointment:(
Is this a mandrake specific bug, and is there anything I can do to make it work?

By Anders at Sat, 2001/06/02 - 5:00am

actually... the help system depends on some of the 'docbook' related stuff on the kde ftp site.

it *would* be really nice if the kdesupport/kdelibs/kdebase incorporated some of the 'missing' components to make sure that the helpcenter *worked* on a basic install. Of course some of the docbook/sgml/etc.., etc... gurus might argue differently - but I'm sure other users would agree ;-0

By Jason Byrne at Sat, 2001/06/02 - 5:00am

This is great work!
I just tried Kdict and it's REALLY cool!
I also enjoy the new Kmail-features! (I still miss account-specific mailfilters though...)

Useragent settings in Konqueror finally works so now I can FINALLY use my online-banking (foreningssparbanken.se) with Konqueror!!!
Using home.se's webmail still doesn't work though... (wwwmail.home.se) :( It immideatly says "You've been logged out because of inactivity, click here to login again", but when I do I get the same message...

Anyway, khtml seems a LOT more immune to buggy html/javascript than in 2.1.2!

Great work guys and gals! I can't wait for a stable 2.2 release!

Note: I use CVS from the 31st...

By Per Wigren at Sat, 2001/06/02 - 5:00am

I have been using foreningssparbanken.se with Konqueror for long times. It worked with 2.1.1 and I think some versions before that too (I don't remember exactly).

By Erik at Sat, 2001/06/02 - 5:00am

Huh? It has never worked for me before because konqueror always refused to save the useragent settings... "This brower is not supported! You net Netscape 4 or Internet Explorer 4 or better".. ;-p

By Per Wigren at Sun, 2001/06/03 - 5:00am

I guess you have been using KDE 2.1 before. KDE 2.1.1 saved useragents properly.


By Torsten Rahn at Sun, 2001/06/03 - 5:00am

Did somebody try Konqueror with www.seb.se? SEB will only allow people using Netscape 4.x or MSIE 4.x to do their online banking (regardless of supported protocols or standards for the browser used). Mozilla 5, Netscape 6, Opera 5 or Konqueror haven't worked for me.

Checking webmail on webmail.tele2.se with Konqueror 2.1.1 works fine but when sending mail the window doesn't change after clicking the "send" button (but the mail is actually sent).

By Niklas Lönnbro at Sun, 2001/06/03 - 5:00am

Yes I have tried SEB with Konqueror 2.1.1 and it failed. Changing user agent did not help, Konqueror choked on some javascript. Netscape 4.7x worked.

By Erik at Mon, 2001/06/04 - 5:00am

I have a scanner that works great with sane but when i click on the scan image option in koffice i get the error No scan service available. i'm useing the mandrake 8.0 rpms. Do I need to reconile any source rpms to get the scan service to work?


By Craig at Sat, 2001/06/02 - 5:00am


i´ve just installed kde2.2alpha2 on my SuSE7.0. And i have a problem: licq dont work. it is missing the file : libkfile.so.3. But this file is in /opt/kde2/lib. I tried to compile it again, but this didnt solve it. Does anyone know this prob or better, does anyone know an solution? Under kde2.1.1 it works fine. Or do i need to install alpha1 an the kdelibs2.1.2 before the alpha 2?


By Bastian at Sat, 2001/06/02 - 5:00am

How I can disable animated cursors? Looks greats, but makes slower my desktop

By ViRgiLiO at Sat, 2001/06/02 - 5:00am

Looks great? Humm i have a fast system and it's lagging and is very anoying. i can't run kdesktop anymore. well i can but it sucks. how do i turn it off. it's like the paper clip in office in the way. And if you watch a movie it stays on the screen till it timeouts. How do i turn it off?

By AC at Sat, 2001/06/02 - 5:00am

> it's like the paper clip in office in the way
> How do i turn it off?

Yes how never see the paper clip in the kicker bar ?
(I am a little tired to close this program each time I open KDE...)

By Alain at Sun, 2001/06/03 - 5:00am


Control Center->Look and Feel->Launch Feedback

By thilor at Sat, 2001/06/02 - 5:00am

Where is that option? I can't see in my kcontrol.

By ViRgiLiO at Sun, 2001/06/03 - 5:00am

it's in kde cvs post 2.2alpha2.

i think you can't disable it in this alpha release.

By Evandro at Mon, 2001/06/04 - 5:00am

Why can't we stop animations just press ESC, like in Netscape/Mozilla?......

I hate to click right mouse button and choose "Stop Animations" from PopUp menu always, when I open a new Konqueror window.

Is there an option in the "Preferences" to AUTOMATICALLY stop all the animations/sounds, or is it impossible? If impossible, can we expect this VERY IMPORTANT feature in the near future?

(For example: if I open 4-5 Konqueror windows -- animated gifs in each window --, my Celeron 433 Mhz processor is overloaded.)

By NÉMETH Balázs at Mon, 2001/06/04 - 5:00am

Does anyone use konqueror with the games at www.pogo.com?

By Jim Paquette at Tue, 2001/06/05 - 5:00am

How about Flash plugin in Konqueror?
It don't work whith KDE 2.1.1
Does anybody use this plugin?

By Milan Svoboda at Wed, 2001/06/06 - 5:00am

The flash plugin works in konqueror. Have you installed flash plugin in netscape ?

By vk at Thu, 2001/06/07 - 5:00am

I've tried netscape with flash plugin
and it work good(sometime :-).
Konqueror can play flash file if it's only
what is doing. For example some clip or game
it can play. But when is that clip in
web page, or in web page with more flash content
konqueror doesn't display them. Some times crash or freeze.
Try this page with konqueror: www.flashfun.cz for example.
there are many flash clips.
I bet you konqueror crash.

I'm using newest flash plugin (5.x or something) wich is availible for download.

By Milan Svoboda at Thu, 2001/06/07 - 5:00am

Ahh.. I am sorry to disappoint you!
Konqueror played that flash page as good as (...........)!
Wait, I wanted to write netscape in (...) but when I open the url in netscape, once it crashed! then in second try it demands for flashplayer plugin inspite of flash plugin installed! i checked that.

Perhaps I or you live in an inverted world. -:)

BTW, I have flash4 plugin and I have also installed mozilla's plugins.This might be a clue.

By vk at Fri, 2001/06/08 - 5:00am