KDE 3.2 Beta 2 "Dobra Voda" is Waiting For You

Our first KDE 3.2 Beta "Rudi" was a huge success and resulted in over 2000 resolved bugs. As the code still has some rough edges, we decided to go for another beta. So here it is: Dobra Voda. Please continue reporting problems you see with it, your testing is much appreciated. You can download Dobra Voda at Currently we have binaries for Fedora, Slackware and SUSE, besides the sources.


Found the problem, in an earlier attempt to setup the dvd for mythtv, I have likely executed the command:

sudo usermod -Gcdrom mythtv

however usermod without "-a" would wipe all existing groups, which in turn broke the sound (and video capturing ...). "-a" means append and should likely be on by default to avoid such mistakes, by users.
"-a" is surely in the man page for usermod -G. Though it is possible the avarage impatient user would not get to that last sentence.

By Amir at Tue, 2006/12/12 - 6:00am

Does KDE-3.2 support changing distance between icons at konqueror? One thing I notice between Nautilus and Konqueror is that space between icons at Nautilus is wider (only 5 icons at one row, konqueror has 7 icons at one row at 1024 x 768), so it is easier for me to read or look for spesific content.

I search through konqueror options but still not get it.
I think this is one of usability issue.


By Adi Wibowo at Thu, 2003/12/11 - 6:00am

> Does KDE-3.2 support changing distance between icons at konqueror?

Not that I know of.. I don't think anybody has requested it either.

hit up and file a wishlist bug :)

I would like it too.

By anon at Thu, 2003/12/11 - 6:00am

If you 'feature request it' and put the bug number in this thread, I will vote add my vote.

By ac at Thu, 2003/12/11 - 6:00am

imwheel doesn't do it any longer on SuSE 9.0.

BTW Button 6+7 do horizontal window scrolling fine.
What about button 8 (MX700)? Would be cool for "app switching".


By Dieter Nützel at Thu, 2003/12/11 - 6:00am

How did ever managed to utilize buttons 6 and 7 for anything usefull?
(my mouse is mx500 -- same as mx700, only corded)

By SHiFT at Thu, 2003/12/11 - 6:00am

You'd better reserve the 8th one for mouse gestures (KControl->KDE components->KHotKeys). And I'd actually like to know if it really works with button > 5 :).

By Luboš Luňák at Thu, 2003/12/11 - 6:00am

OK, let's make a "deal"...;-)

Yes, it _works_ with 6 or 7.
Played somewhat with KHotKeys before...
But I had to erase the default gestures.
After I did my own it _is_ working with the "middle button" (2), 6 or 7.
I'm testing with this now:

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "ButtonNumber" "8"
Option "Buttons" "8"
Option "Device" "/dev/mouse"
Option "InputFashion" "Mouse"
Option "Name" "PS/2-Mouse;ExplorerPS/2"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "6 7"

What's the difference between "ButtonNumber" and "Buttons"?

Now, please tell me how I can change the 6/7 function from "LEFT|RIGHT"
to "ALT+LEFT|RIGHT"...;-)

The eight button do NOT work with XFree86 (XFree86 CVS/DRI CVS) 8-(
No response with X's "xev".

Any glue?


By Dieter Nützel at Thu, 2003/12/11 - 6:00am

All my attempts to run the kde-3.1.4 configure script has failed since it just does not detect the libqt-mt of QT-3.2.x !! BTW, the library qt-mt is very much there. Any help is welcome.

By hapless user at Thu, 2003/12/11 - 6:00am

It worked for me. Have you set the QTDIR environment variable in your profile? And have you put the qt library path in LD_LIBRARY_PATH and the qt executable path in your PATH?

By Luke Sandell at Sat, 2003/12/13 - 6:00am

I had the same problem.
Upon 3 days of investigation I found that isue actually with freetype library. If /usr/X11R6/lib and /usr/local contains different versions of freetype, qt-3.2.3 linkes with unresolved references.
Synchronise freetype versions (as noted is freetype's UPGRADE.UNX file) and recompile qt.

Hope it helps :)

(And sorry for bad english)

By deadkitten at Mon, 2003/12/15 - 6:00am

I discovered the exact same problem. My qt was compiled with freetype-2.0.8 but is linked with a freetype lib of different version (2.1.4) intentionally. While qt/kde apps run just fine with this, compiling is a problem.

By hapless user at Mon, 2003/12/15 - 6:00am

I see that KDE 3.2 is not compatible with kdebase-suse <= 9.0. Can I force kdebase3 to install even though it wants a newer kdebase-suse, and will that still work? If I uninstall kdebase-suse, what will that break on my SuSE 9.0 system? Is there an updated kdebase-suse available?

By Brian Kendig at Thu, 2003/12/11 - 6:00am

i installed kde3.2b2 successfully with suse 9 ... i just forced the packages to install even when kdebase-suse complained ... no problems whatsoever ... but don't blame me if you do have any problems ;)

By Anonymous at Fri, 2003/12/12 - 6:00am

I finally satisfied all the dependency issues with SuSE 9.0, and got KDE 3.2b2 installed. But now my panel is completely empty -- no Kicker menu, no clock or battery monitor, no list of open windows, no nothing but a grey bar with an arrow at one end to let me show or hide it.

I think I remember seeing a report of this a while ago, and how to fix it, but now I'm not able to find that info again... isn't there just a file to delete?

By Brian Kendig at Fri, 2003/12/12 - 6:00am

I just installed this new beta, and now XMMS using the plugin no longer works. Any thoughts or ideas?


By Laura at Sat, 2003/12/13 - 6:00am

In the same boat with no paddle here.

I initially thought that it just needed a recompile with the new artsd libs, but that didn't help at all.

Anytime I try and play a file in XMMS with the lib-artsd, XMMS will hang for about 10-15 secconds, and then exit.

By John E. Martin at Sun, 2003/12/14 - 6:00am

compile your kde with arts-1.1.4, xmms doesn't work with arts-1.1.9x or newer, it is just IMPOSSIBLE, read it at the forum.

By tizz at Sun, 2003/12/21 - 6:00am

I downloaded and compiled Konqueror 3.1.94 and noticed it was missing some
of the nicer features previously seen in 3.1.4. Notably, the ability to
"Archive" web pages, the ability to view the document tree, and the ability
to quickly switch browser identification from the menubar. Anyone know what
happened? My 3.1.4 packages were from Yoper.


By Luke Sandell at Sat, 2003/12/13 - 6:00am

You have to install the kdeaddons package.

By Anonymous at Sat, 2003/12/13 - 6:00am

I am using Mandrake 9.2, and just installed a copy of KDE 3.2 beta from cooker, but I got a locale problem. Originally the locale of old KDE 3.1.3 and Gnome 2.4 were both using zh_CN.GB2312, but now KDE is using UTF-8, I did checked my locale setting, it is zh_CN,
Where can I set the locale of KDE back to GB2312? thanks for any help

By Paul at Sat, 2003/12/13 - 6:00am

Hi; ppl;

I just wanna say it's cool to se a release name in some other language than english; and that doesn't have to do with some bird, galaxies or some strange flashy SF name ... For those unlucky who doesn't speak Croatins; "Dobra Voda" means "Good Water". :)


By a. m. at Sun, 2003/12/14 - 6:00am

Installed beta2, and it feels fast.
But kmail crashes when i want to attach a zip-file or other stuffed file.
Other people have the same problem?

By Frank Mutsaers at Mon, 2003/12/15 - 6:00am

Just installed it,
looks great, love the transparent taskbar!!! :)
smooth as, really a lot faster!
im using it on fedora core 1,
i would assume that thoes rpms will work on redhat 9 & maby 8
BUT there will be a few more dependancys you will have to get as well!

good luck
nice work KDE guys!

sorry for the spelling.

By Sam at Tue, 2003/12/16 - 6:00am

Well, it sure is fast, and seems stable enough, but I do have a couple issues with the FC1 RPMs.

My system is Fedora Core 1 (stock) running 3.14. Installed pretty much everything bar the devel packages, quanta and koffice. I got one dependency error message for (existing quanta install), so I backed that up, installed via 'rpm -Uvh *.rpm --nodeps' and manually restored to its original location. My issues are thus:

1> I don't get a panel. My desktop loads fine, it even restored my previous session without difficulty, but no panel, no how. I can edit the panel options in kcontrol, but can't get a panel to pop. When I run 'kicker' from a command prompt as user, I get a silent failure - no bash output, no process, no panel. When i run 'kicker' as root, I get a default panel (not my customised one), but anything I run from that panel has root privileges, so that's not gonna fly. The file /usr/share/config/kickerrc shows the specs of the root panel; /home/magpie/.kde/share/config/kickerrc shows the settings I made for my user panel. They seem correct. Any ideas on how to restore the correct panel?

2> My monospace font is bold by default. I'll cope :)


By Magpie at Tue, 2003/12/16 - 6:00am

My system is Fedora Core 1 (stock) running 3.14.

I should say was running 3.14. It's Dobra Voda now...


By Magpie at Tue, 2003/12/16 - 6:00am

try to run "kdeinit kicker" and look at the output. I had the same problem when updating kde; there was a broken panel applet which caused kicker to crash (did you use kbinaryclock :)

By hoirkman at Mon, 2003/12/22 - 6:00am


You can remove ~/.kde/share/config/kickerrc and then start kicker from command line. It will run kde panel with default settings so you will need to customize it again.



By pawel at Wed, 2004/01/07 - 6:00am

Does anyone have problem with unmount dvdroms or cdroms? There are 2 dvdroms in my computer. I compiled and run "Dobra Voda" on Fedora and ASPLinux 9 (the same as Red Hat 9) and had got problem on both. It takes a long uncertain time to wait until dvdroms can be unmounted. Until that time I get messages "umount: /mnt/cdrom: device is busy", "Eject /dev/cdrom failed!" "The program kdeeject %v' can't be found" (although kdeeject script exists in /usr/bin). The message depends on a chosen item from the menu that appears on a right click of a mouse on dvdrom device icon. With KDE-3.1.1/3.1.4 everything works fine.
Does anybody knows how to solve the problem?
Thanks in advance.

By Alexander Malashenko at Tue, 2003/12/16 - 6:00am

I couldn't find any release notes for beta2 and I looked in bugs for this.

I upgraded from Fedora Core 1's KDE3.1.4 to beta2 and the Splash screen looks weird (big blue blinking squares). In Control center the Splash Screen page looks kindof blank as well.

Is this a known bug?

btw. great release! Love on first sight. Especially fond of the "Preloading" feature under KDE performance - Konquerer is there instantly when I click the icon.. Kapow!!! and Plastic is beautiful... I could go on.... drool..

By Erik at Sun, 2003/12/21 - 6:00am

By Alexander Malashenko at Sun, 2003/12/21 - 6:00am

Thanks.. That did the trick...

Have you gotten other splashscreens installed as well? It swallows whatever I throw at it, without updating the list of splashscreens.

By Erik at Mon, 2003/12/22 - 6:00am

Seems like most of the Splashes on are missing a Theme.rc file in the archive, that's why they're not showing in the control center.

Copying and adapting the Theme.rc from /usr/share/apps/ksplash/Themes/BlueCurve to my .kde/share/apps/ksplash/Themes/xxx cusom installed splashes seem to fix everything.

The Theme.rc must be new with 3.2?

By Erik at Mon, 2003/12/22 - 6:00am

I can see all my themes fine, but for some reason the Apply button is always grayed out no matter what I do.


By Blair at Mon, 2003/12/22 - 6:00am

After some poking around I'm not able to Apply a different splash... I'm in the exact same spot as you.

Still stuck with the standard Fedora splash screen.

By Erik at Tue, 2003/12/23 - 6:00am

I'm using SuSE 8.2 and updated to KDE 3.1.92 and I also am unable to update my splash screen. The "apply" button, as above noted, is greyed-out. Has anyone found out how to fix this? I really don't like the splash screen that is on there now...

By Justin at Wed, 2004/01/21 - 6:00am

Ok, I downloaded all the *rpm's for Red Hat9. How do I install these, it keeps saying dependencies errors.

Is there an order?
Please help

By Jason at Tue, 2003/12/23 - 6:00am

I can't find a list of libs on which this beta depends. I am on a LFS-system running KDE 3.1.4 at the moment. Are there any libs I should install before compiling the beta so I get all features?


By Norbert Moendjen at Thu, 2003/12/25 - 6:00am

Hi all,

I'm a bit eager to compile the beta2 with konstruct. Everything works fine, except compiling the kdebase. kdebase did not compile kfm (and maybe some other stuff). - So I compiled kdebase "by hand". The result of it is always the same:

make[3]: Entering directory `/mnt/hdb6/new/konstruct/kde/kdebase/work/kdebase-3.1.94/kate/utils'

/bin/sh ../../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -D_GNU_SOURCE -o -rpath /opt/kde3.2-beta2/lib -L/usr/X11R6/lib -L/opt/kde3.2-beta2/lib -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined dockviewbase.lo messageview.lo listboxview.lo -lkdeui -lkdecore -lkio

collect2: ld terminated with signal 11 [Segmentation fault]

make[3]: *** [] Fehler 1

make[3]: Leaving directory `/mnt/hdb6/new/konstruct/kde/kdebase/work/kdebase-3.1.94/kate/utils'

make[2]: *** [all-recursive] Fehler 1

make[2]: Leaving directory `/mnt/hdb6/new/konstruct/kde/kdebase/work/kdebase-3.1.94/kate'

make[1]: *** [all-recursive] Fehler 1

make[1]: Leaving directory `/mnt/hdb6/new/konstruct/kde/kdebase/work/kdebase-3.1.94'

make: *** [all] Fehler 2

Any help is welcome.

Merry christmas,


By nero2005 at Thu, 2003/12/25 - 6:00am

> Everything works fine, except compiling the kdebase. kdebase did not compile kfm

The reason may be that there is no kfm in kdebase. :-)

> collect2: ld terminated with signal 11 [Segmentation fault]

This shouldn't happen. Try to upgrade to a newer version of ld.

By Anonymous at Fri, 2003/12/26 - 6:00am

collect2: ld terminated with signal 11 [Segmentation fault] is most the times an hardware defect. Overheating or bad rams. If it's overheating the just type make a second time after your cpu has cooled down.

Ciao Nobbe

By Norbert Moendjen at Sat, 2003/12/27 - 6:00am

That's it! Overheating of AMD-CPU and a bad (though the most recent) version of binutils incl. "ld" causes the error. Thanks. But how can I avoid the error of ld?
Meanwhile I watch out for kfm :)


By nero2005 at Sun, 2003/12/28 - 6:00am


kdebindings doesnt compile kdejave error is
make[4]: Entering directory `/usr/src/kde/kdebindings-3.1.94/kdejava/koala/kdejava'
/bin/sh ../../../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -DNDEBUG -DNO_DEBUG -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -march=athlon-xp -m3dnow -msse -mfpmath=sse -mmmx -O3 -pipe -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=4 -maccumulate-outgoing-args -ffast-math -fprefetch-loop-arrays -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -o -rpath /opt/kde/lib -L/usr/X11R6/lib -L/opt/qt/lib -L/opt/kde/lib -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 1:0:0 libkdejava_la.all_cpp.lo ../../../qtjava/javalib/qtjava/ -lkjs -lkscript -lkhtml -lkmid -lkspell -lkio
.libs/libkdejava_la.all_cpp.o: In function `Java_org_kde_koala_MouseReleaseEvent_newMouseReleaseEvent__Lorg_kde_qt_QMouseEvent_2IILjava_lang_String_2Ljava_lang_String_2Lorg_kde_koala_DOMNode_2J':
.libs/libkdejava_la.all_cpp.o(.text+0x6bc2e): undefined reference to `khtml::MouseReleaseEvent::s_strMouseReleaseEvent'
.libs/libkdejava_la.all_cpp.o(.gnu.linkonce.t._ZN5khtml14MouseMoveEventD0Ev+0x29): undefined reference to `khtml::MouseEvent::~MouseEvent [not-in-charge]()'
.libs/libkdejava_la.all_cpp.o(.gnu.linkonce.t._ZN5khtml14MouseMoveEventD1Ev+0x25): more undefined references to `khtml::MouseEvent::~MouseEvent [not-in-charge]()' follow
collect2: ld returned 1 exit status
make[4]: *** [] Error 1
make[4]: Leaving directory `/usr/src/kde/kdebindings-3.1.94/kdejava/koala/kdejava'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/src/kde/kdebindings-3.1.94/kdejava/koala'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/kde/kdebindings-3.1.94/kdejava'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/kde/kdebindings-3.1.94'
make: *** [all] Error 2
kdesdk won't compile the error is
In file included from /usr/include/FlexLexer.h:47,
/usr/include/c++/3.2.1/backward/iostream.h:36: using declaration `istream'
introduced ambiguous type `istream' warning: "YY_STACK_USED" is not defined In member function `virtual int GettextBaseFlexLexer::yylex()': cannot convert `std::istream*' to `istream*' in assignment In member function `void
GettextBaseFlexLexer::yy_load_buffer_state()': cannot convert `istream*' to `std::istream*' in assignment In member function `void
GettextBaseFlexLexer::yy_init_buffer(yy_buffer_state*, std::istream*)': cannot convert `std::istream*' to `istream*' in assignment warning: "YY_MAIN" is not defined
make[4]: *** [pofiles.lo] Error 1
make[4]: Leaving directory `/usr/src/kde/kdesdk-3.1.94/kbabel/common/libgettext'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/usr/src/kde/kdesdk-3.1.94/kbabel/common'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/kde/kdesdk-3.1.94/kbabel'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/kde/kdesdk-3.1.94'
make: *** [all] Error 2
kdedevelop won't configure I am still on test

Any help would be nice. Everything else is running fine and I like the beta

Ciao Nobbe

By Norbert Moendjen at Sat, 2003/12/27 - 6:00am

cd to kbabel's parent dir (where your "making") and run

sed -i 's/class istream;/#include /' ./kbabel/common/libgettext/ && make


By Ulrich van Brakel at Thu, 2006/08/24 - 5:00am

Hi, I've installed on my Slack 9.1 box. Are you sure it's a "beta"?! Pretty stable, good-looking and fast. It goes very well with the Slack!!

Thank you very much! I'm anxious about the final version (3.2). I think it will be a state-of-art desktop, better than everyone else.

By Paulo Igor at Sun, 2003/12/28 - 6:00am

Does anyone have problems with AA fonts in kde 3.2? I'm running slack 9.1 btw.

By borgware at Mon, 2004/01/05 - 6:00am

I can find no way to make a new folder in konqueror when using the detailed list view. No matter where I right click, I get a context menu for a file with no 'create new' choice. I have to switch to icon view to be able to do that.

This sucks, and is different from how it was in konqueror 3.1.x. In 3.1.4, you could right click on any column but the name column and get a generic menu (including 'create new' and 'paste')

Now, you cannot right click to paste a file. You can do this in the menu of course (still lost functionality imho) but it is impossible to create a new folder. It was like this in beta 1, and it is like this in beta 2.

Is it this way on purpose?

By Jason W at Tue, 2003/12/30 - 6:00am

Resize either your columns or your window and right click after the last column.

By Anonymous at Tue, 2003/12/30 - 6:00am

heh that works all right. If I fullscreen konq and squish a couple columns down, it works. Thanks

I still think it's less than optimal, especially compared with how it was. Something like this was reported as a bug for 3.1.1 The reporter was told he could click in any column but the name column (he was clicking in the blank part of the name column), so no bug. Now, you can't even do that. Can't click in any column. Ugh. What's the reasoning behind this?

Or since it's likely to be this way forever, can anyone give me a clue about where in the code the change was made? Could be a fun learning experience :D

By Jason W at Tue, 2003/12/30 - 6:00am

Hi i had some problems with my and . But it wasn't a problem. I just copyed the old files from my other computer.

I think that the KDE team have done a great work.
I have some minder problems but i think it will be shalled sooner or later.
One problem i have is whit wine. I cant play Counter-stike in KDE. But other games like Warcraft works.

I awate for the coming programs that will shall some minter problems.

Great job KDE .

/ Teo

Hope you understand what i mean. Have a littel bit problems with the spelling in English.

By Teodor Engqvist at Sun, 2004/01/04 - 6:00am