<!DOCTYPE html>
<html lang="en" version="XHTML+RDFa 1.0" dir="ltr" 
  xmlns:fb="http://ogp.me/ns/fb#"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#">
    <head profile="http://www.w3.org/1999/xhtml/vocab">
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="https://dot.kde.org/sites/all/themes/neverland/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="The KDE Community is happy to announce that we have been selected to participate in Google Summer of Code. This will be our our 14th year of mentoring students. Attention students: If you are a student who would like to work with KDE this summer you can apply to SoC, find more info on the KDE GSoC wiki page. Please note that your project proposal will need to link to some" />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="https://dot.kde.org/2019/02/27/google-summer-code-2019" />
<link rel="shortlink" href="https://dot.kde.org/node/4373" />
<meta property="og:site_name" content="KDE.news" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://dot.kde.org/2019/02/27/google-summer-code-2019" />
<meta property="og:title" content="Google Summer of Code 2019" />
<meta property="og:description" content="The KDE Community is happy to announce that we have been selected to participate in Google Summer of Code. This will be our our 14th year of mentoring students. Attention students: If you are a student who would like to work with KDE this summer you can apply to SoC, find more info on the KDE GSoC wiki page. Please note that your project proposal will need to link to some commits to the KDE codebase, so get started now fixing some bugs! If you are wondering what you can work on, also check out our ideas page. Come and talk to the team on Matrix at kde-soc:kde.org, on IRC in the #kde-soc channel or join the student mailing list." />
<meta property="og:updated_time" content="2019-02-27T13:25:39+00:00" />
<meta property="article:published_time" content="2019-02-27T09:10:36+00:00" />
<meta property="article:modified_time" content="2019-02-27T13:25:39+00:00" />

        <title>
            Google Summer of Code 2019 | KDE.news        </title>

        <link type="text/css" rel="stylesheet" href="https://dot.kde.org/sites/dot.kde.org/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://dot.kde.org/sites/dot.kde.org/files/css/css_9kIpF7moV7fx1BGgTXLyvfB2C8lXuoD3fcn9PN5K0gI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://dot.kde.org/sites/dot.kde.org/files/css/css_PGbJgHCUCBf4dg7K9Kt8aAwsApndP4GZ9RuToPy3-Fk.css" media="all" />
        <link href="//cdn.kde.org/css/bootstrap.css" rel="stylesheet" type="text/css" media="screen, projection" />
        <link href="//cdn.kde.org/css/bootstrap-responsive.css" rel="stylesheet" type="text/css" media="screen, projection" />
        <link href="//cdn.kde.org/css/bootstrap-drupal.css" rel="stylesheet" type="text/css" media="screen, projection" />
    </head>

    <body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-4373 node-type-story i18n-en" >
        <script type="text/javascript" src="//cdn.kde.org/js/jquery.js"></script>
        <script type="text/javascript" src="//cdn.kde.org/js/bootstrap.js"></script>
        <script type="text/javascript" src="//cdn.kde.org/js/bootstrap-neverland.js"></script>

        <div id="skip-link">
            <a href="#main-content" class="element-invisible element-focusable">
                Skip to main content            </a>
        </div>

                
<div id="header" class="navbar navbar-static-top Neverland">
    <div class="navbar-inner">
        <div class="container">
            <a class="btn btn-navbar" data-toggle="collapse" data-target="#neverland-menu">
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
            </a>

                            <a class="brand" href="/" title="Home" rel="home">
                    <img src="https://dot.kde.org/sites/all/themes/neverland/logo.png" alt="Home" />
                </a>
            
            <div id="neverland-menu" class="nav-collapse">
                <ul class="nav">
                    <li><a href="/content/contribute-story"><h2>Contribute<small>Submit an article about your project to KDE.News</small></h2></a></li><li><a href="http://www.kde.org/community/whatiskde/"><h2>About KDE<small>Learn about KDE software and the community</small></h2></a></li><li><a href="http://www.kde.org/download/"><h2>Download KDE<small>Download KDE Desktop and related applications</small></h2></a></li>                </ul>
            </div>
        </div>
    </div>
</div>

<div class="container">
            <div class="row">
            <div class="span12">
                <div class="subnav main-menu">
                    <div class="pull-right">
                                            </div>

                    <ul class="nav nav-pills">
                        <li><a href="http://www.kde.org"><i class="icon-globe"></i>&nbsp;KDE.org</a></li><li><a href="http://forum.kde.org/"><i class="icon-comment"></i>&nbsp;KDE Forums</a></li><li><a href="http://wiki.kde.org"><i class="icon-book"></i>&nbsp;KDE Wikis</a></li><li><a href="http://blogs.kde.org"><i class="icon-user"></i>&nbsp;Developer Blogs</a></li><li><a href="http://www.planetkde.org"><i class="icon-bullhorn"></i>&nbsp;Planet KDE</a></li>                    </ul>
                </div>
            </div>
        </div>
    
    
    
    <div class="row" id="content">
        <div class="span9">
            
            
                                        
            
            
                              <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-4373" class="node node-story node-promoted node-full node-body clearfix" >
    <table width="100%" cellspacing="0" cellpadding="0">
        <tr>
                                                <td class="node-meta">
                        <div class="node-date-wrapper">
                            <div class="node-date">
                                <div class="node-dt-small">
                                    FEB                                </div>

                                <div class="node-dt-big">
                                    27                                </div>

                                <div class="node-dt-small">
                                    2019                                </div>
                            </div>
                        </div>
                    </td>
                                        
            <td rowspan="2" class="node-content
                ">

                
                <h2 >
                    <a href="/2019/02/27/google-summer-code-2019">
                        Google Summer of Code 2019                    </a>
                </h2>

                
                                    <div class="meta submitted">
                        <i class="icon-user"></i>
                        Submitted by <a href="/users/paul-brown">Paul</a>                     </div>
                
                <div class="content">
                    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"><p><img class="alignnone size-full wp-image-135" src="https://dot.kde.org/sites/dot.kde.org/files/GSoC2019_02.jpg" alt="GSoC" width="800" /></p>
<p><b>The KDE Community is happy to announce that we have been selected to participate in <a href="https://summerofcode.withgoogle.com/organizations/">Google Summer of Code</a>. This will be our our 14th year of mentoring students.</b></p>
<p>Attention students: If you are a student who would like to work with KDE this summer you can apply to SoC, find more info on <a href="https://community.kde.org/GSoC ">the KDE GSoC wiki page</a>. Please note that your project proposal will need to link to some commits to the KDE codebase, so get started now fixing some bugs! If you are wondering what you can work on, also check out our <a href="https://community.kde.org/GSoC/2019/Ideas">ideas page</a>.</p>
<p>Come and talk to the team on Matrix at <a href="https://webchat.kde.org/#/room/#freenode_#kde-soc:matrix.org">kde-soc:kde.org</a>, on IRC in the <a href="irc://#kde-soc@freenode.net">#kde-soc</a> channel or join the <a href="https://mail.kde.org/mailman/listinfo/kde-soc">student mailing list</a>.</p>
<p align="center">
<iframe width="560" height="315" src="https://www.youtube.com/embed/S6IP_6HG2QE" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe></p>
<!--break--></div></div></div>                </div>

                                    <div class="link-wrapper">
                        <ul class="links inline"><li class="comment-add first last"><a href="/comment/reply/4373#comment-form" title="Share your thoughts and opinions related to this posting.">Add new comment</a></li>
</ul>                    </div>
                
                            </td>
        </tr>

                    <tr>
                <td class="node-sep">
                                    </td>
            </tr>
            </table>
</div>  </div>
</div>
  </div>
                    </div>
        <div class="span3" id="sidebar">
            
                  <div class="region region-sidebar-first">
    <div id="block-search-form" class="block block-search">

    
  <div class="content">
    <form action="/2019/02/27/google-summer-code-2019" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-KaJnoQK6lOp1zmZiRkh9gywaDDJ_HRH9G6jq5TFfEt0" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>
</div>
<div id="block-block-4" class="block block-block">

    
  <div class="content">
    <div style="font-size: 14px; color: #909090; padding-bottom: 0.5em;">DONATE <a href="https://www.kde.org/community/donations/index.php#money">(Why?)</a><img src="https://www.kde.org/media/images/paypal.png" style="padding: 0px; border: none; margin: 0px; margin-left: 10px;float: right;" alt="paypal" /></div>
<form action="https://www.paypal.com/en_US/cgi-bin/webscr" method="post"><input type="hidden" name="cmd" value="_donations" /><input type="hidden" name="lc" value="GB" /><input type="hidden" name="item_name" value="Development and communication of KDE software" /><input type="hidden" name="custom" value="//dot.kde.org/donation_box" /><input type="hidden" name="currency_code" value="EUR" /><input type="hidden" name="cbt" value="Return to www.kde.org" /><input type="hidden" name="return" value="https://www.kde.org/community/donations/thanks_paypal.php" /><input type="hidden" name="notify_url" value="https://www.kde.org/community/donations/notify.php" /><input type="hidden" name="business" value="kde-ev-paypal@kde.org" /><input style="text-align: right; padding-right: 1em; border: 1px solid #CCC; width: 60px; height: 23px; " type="text" name="amount" value="10.00" /> €   <button style="cursor: pointer; background-color: #0070BB; border: 1px solid #0060AB; color: #FFF; height: 27px; margin-left: 0.5em;" type="submit">Donate</button><br /></form>
  </div>
</div>
<div id="block-views-planetkde-block-1" class="block block-views">

    <h2>Planet KDE</h2>
  
  <div class="content">
    <div class="view view-planetkde view-id-planetkde view-display-id-block_1 view-dom-id-e0f86d31ccc4fe84b693b825c95503ad">
        
  
  
      <div class="view-content">
      <div class="item-list">    <ul>          <li class="views-row views-row-1 views-row-odd views-row-first">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="https://blog.qt.io/blog/2019/02/26/mqtt-version-5-updates-apply-qt-mqtt/">MQTT version 5 updates and how they apply to Qt MQTT</a></span>  </div>  
  <div class="views-field views-field-author">        <span class="field-content"><span class="planet-author">by Qt Dev Loop</span></span>  </div></li>
          <li class="views-row views-row-2 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="https://pointieststick.com/2019/02/24/this-week-in-usability-productivity-part-59/">This week in Usability &amp; Productivity, part 59</a></span>  </div>  
  <div class="views-field views-field-author">        <span class="field-content"><span class="planet-author">by Nate Graham (ngraham)</span></span>  </div></li>
          <li class="views-row views-row-3 views-row-odd">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="https://euroquis.nl/bobulate/?p=2053">Alternatives to rioting</a></span>  </div>  
  <div class="views-field views-field-author">        <span class="field-content"><span class="planet-author">by Adriaan de Groot ([ade])</span></span>  </div></li>
          <li class="views-row views-row-4 views-row-even">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="https://kdenlive.org/en/2019/02/ready-to-test/">Ready to test?</a></span>  </div>  
  <div class="views-field views-field-author">        <span class="field-content"><span class="planet-author">by Kdenlive</span></span>  </div></li>
          <li class="views-row views-row-5 views-row-odd views-row-last">  
  <div class="views-field views-field-title">        <span class="field-content"><a href="https://blog.qt.io/blog/2019/02/21/qt-creator-4-9-beta-released/">Qt Creator 4.9 Beta released</a></span>  </div>  
  <div class="views-field views-field-author">        <span class="field-content"><span class="planet-author">by Qt Dev Loop</span></span>  </div></li>
      </ul></div>    </div>
  
  
  
  
      <div class="view-footer">
      <div class="more-link">
    <a href="http://planetkde.org/">More</a>
</div>
    </div>
  
  
</div>  </div>
</div>
<div id="block-aggregator-feed-2" class="block block-aggregator">

    <h2>KDE Store</h2>
  
  <div class="content">
    <div class="item-list"><ul><li class="first"><a href="https://store.kde.org/p/1292186">City ne2 light EQ [Wallpapers KDE Plasma]</a>
</li>
<li><a href="https://store.kde.org/p/1292171">Breeze Chameleon [Plasma Splashscreens]</a>
</li>
<li><a href="https://store.kde.org/p/1292169">Breeze Chameleon [SDDM Login Themes]</a>
</li>
<li><a href="https://store.kde.org/p/1292168">Breeze Chameleon [Konsole Color Schemes]</a>
</li>
<li><a href="https://store.kde.org/p/1292166">Breeze Chameleon [Aurorae Themes]</a>
</li>
<li><a href="https://store.kde.org/p/1292165">Breeze Chameleon [Plasma Color Schemes]</a>
</li>
<li><a href="https://store.kde.org/p/1292164">KDE Plasma Abstract 155 HD [Wallpapers KDE Plasma]</a>
</li>
<li class="last"><a href="https://store.kde.org/p/1292162">Breeze Chameleon [Plasma Themes]</a>
</li>
</ul></div><div class="more-link"><a href="/aggregator/sources/2" title="View this feed&#039;s recent news.">More</a></div>  </div>
</div>
  </div>

            
        </div>
    </div>

            <footer class="copyright align-center">
              <div class="region region-footer">
    <div id="block-block-2" class="block block-block">

    
  <div class="content">
    <p><a rel="nofollow" href="http://creativecommons.org/licenses/by/3.0/"></a>  This work by KDE is licensed under a <a rel="nofollow" href="http://creativecommons.org/licenses/by/3.0/">Creative Commons Attribution 3.0 Unported License</a>.</p>
  </div>
</div>
<div id="block-system-powered-by" class="block block-system">

    
  <div class="content">
    <span>Powered by <a href="https://www.drupal.org">Drupal</a></span>  </div>
</div>
  </div>
        </footer>
    </div>
        <script type="text/javascript" src="https://dot.kde.org/sites/dot.kde.org/files/js/js_vDrW3Ry_4gtSYaLsh77lWhWjIC6ml2QNkcfvfP5CVFs.js"></script>
<script type="text/javascript" src="https://dot.kde.org/sites/dot.kde.org/files/js/js_i9-mZxF1wrIj_pHo8CcygMfG3cz35Mlm6odAjzL19fk.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var _paq = _paq || [];(function(){var u=(("https:" == document.location.protocol) ? "https://stats.kde.org//" : "http://stats.kde.org//");_paq.push(["setSiteId", "17"]);_paq.push(["setTrackerUrl", u+"piwik.php"]);_paq.push(["setDoNotTrack", 1]);_paq.push(["trackPageView"]);_paq.push(["setIgnoreClasses", ["no-tracking","colorbox"]]);_paq.push(["enableLinkTracking"]);var d=document,g=d.createElement("script"),s=d.getElementsByTagName("script")[0];g.type="text/javascript";g.defer=true;g.async=true;g.src=u+"piwik.js";s.parentNode.insertBefore(g,s);})();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"neverland","theme_token":"AvapkycPuOntYXxsdPV_zAbZaesqeLttZprfMik_cMA","js":{"misc\/jquery.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/matomo\/matomo.js":1,"0":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/date\/date_repeat_field\/date_repeat_field.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/calendar\/css\/calendar_multiday.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1}},"matomo":{"trackMailto":1},"urlIsAjaxTrusted":{"\/2019\/02\/27\/google-summer-code-2019":true}});
//--><!]]>
</script>
            </body>
</html>
