FEB
4
2004

Qt 3.3 Released; Trolltech CEO on KDE, Linux, Qtopia, .NET/Mono

Trolltech today released Qt 3.3 which among other things features improved .NET support, full 64-bit support, IPv6 and backend support for two more databases. Also new is the -dlopen-opengl configure switch, which is very useful for prelinking Qt and KDE apps against the -PIC compiled nVidia drivers and support for Xft2 client side fonts on X servers without the
RENDER extension. In light of the release, OSNews features an article with TrollTech's CEO, Haavard Nord. Nord says that he sees Linux strengthen its position in both business computing and embedded systems, while he forsees Qtopia and Linux taking over PDAs and Smartphones in the next few years.

Comments

Why no Mono support? What lawsuits, it's an open standard!


By Alex at Thu, 2004/02/05 - 6:00am

kdelibs 3.2 didn't compile against qt 3.3.0b1 (http://bugs.kde.org/show_bug.cgi?id=73565 and 72501); will it work with the final qt 3.3?


By Cloaked Penguin at Thu, 2004/02/05 - 6:00am

Hi!
I have installed qt-3.3.0b1 with kde 3.1.95 and i have removed
the PM_* code and all works fine.

My Setup:
( LFS 5.0 (+minor code modification in some packages to work with 2.6.1 ) + kernel 2.6.1 ( sysfs patches ) + hacked coreutils 5.0 (to
support my "sqlite package management" = install from source and have packages automatic logged to an sqlite database )

Bye Thomas


By schoko at Thu, 2004/02/05 - 6:00am

AOA , Hi ...

Well can you help me out... here

QT 3.3.2 + KDE 3.2.2

I tried to Upgrade my KDE 3.1-10 RedHat to KDE3.2.2

Well, actually i got a lot of dependecy errors.
One of them was "redhat-artwork-0.93-1.i386.rpm" required /usr/lib/qt-3.3

I downloaded qt 3.3.2, extracted in /usr/local/gt, as instructed in its docs and ran ./configure and make commands ....

Then I again tried "# rpm -U redhat-artwork-0.93-1.i386.rpm" and again dependcy error same as above required /usr/lib/qt-3.3

What do i do... ?


By compute.ash at Thu, 2004/05/06 - 5:00am

Please don't give my e-mail!!!

I have the same and I'm trying to resolve it.
I have fedora core1 and i have downloaded kde-3.2.2 rpm for fedora core1!!
I had no problem until i have tried to compile some kde windows decoration (style) from www.kde-look.org many and strange compilation error!!!
So i have decided to download qt-3.3.2 from source and compile and install myself i have again problem with compilation but this in mot important to you what is important is that installation of qt-3.3.2 from source have created problem that you have so I have deinstalled qt compiled from me and qt qt from kde fedora, the probelm isn't resolved nut changed: qt < 1:3.0.4-11 conflicts with redhat-artwork-0.93-1.
Idon't know why, but compilation of qt from source have created tis problem now i think to download redhat-artwork and compile myself, Maybe i could resolve error!!!
I hope this could help you

P.S: Which distribution do you have?


By Francesco Serio at Sun, 2004/07/04 - 5:00am

...and last but not least:

precompiled headers!
This should decrease compiling times significantly!

Kta >8^)


By katakombi at Thu, 2004/02/05 - 6:00am

I have this suse 8.0 box where qt-3.3.0 does not even configure properly. It disables xft with these messages:

Xft auto-detection... ()
Found libXft.a in /usr/X11R6/lib
Found X11/Xft/Xft.h in /usr/X11R6/include
Found X11/Xft/Xft.h in /usr/include
Found Xft version ..
Found X11/Xft/XftFreetype.h in /usr/X11R6/include
Found Freetype version 2.0.8
Could not find freetype2/freetype/freetype.h anywhere in /usr/X11R6/include /usr/include /include
Xft disabled.

On the same system, qt-3.2.2 detects freetype just fine with these messages:

Xft auto-detection... ()
Found libXft.a in /usr/X11R6/lib
Found X11/Xft/Xft.h in /usr/X11R6/include
Found X11/Xft/Xft.h in /usr/include
Found Xft version .
Found X11/Xft/XftFreetype.h in /usr/X11R6/include
Found freetype2/freetype/freetype.h in /usr/include
Xft enabled.

This is strange since /usr/include/freetype2/freetype/freetype.h surely exists. Also "rpm -qa | grep freetype" shows:

freetype-1.3.1-497
freetype2-2.0.8-30
freetype2-devel-2.0.8-30


By goodfella at Thu, 2004/02/05 - 6:00am

Ok, it seems QT-3.3.0 requires freetype-2.0.9 or later versions but the config.tests/x11/xfreetype.test file does not print an error message in such a case.


By goodfella at Fri, 2004/02/06 - 6:00am

There's a bugin the qt configuration scripts which prevents it from working with freetype 2.1.x (it requires 2.0.9 or greater). In qt-3.3.0b1/config.tests/x11/xfreetype.test, line 132, it checks the version number of the freetype library. It requires it to be 2.0.x, for x>9. Changing the numbers in quotes from "2" "0" "9" to "2" "1" "0" worked for me (compiling qt 3.3.0b1 with version 2.1.0)


By Roie_m at Fri, 2004/02/06 - 6:00am

"Three years ago there were only 3-5% commercial Qt developers developing for Linux, but now this number is up to 40%. This has made Trolltech shift focus towards Linux as the main "Unix/X11" platform supported by Qt, along to Windows and Mac.", Haavard Nord, Trolltech's CEO and founder. (http://www.osnews.com/story.php?news_id=5908)
I say, HURRA!


By Pupeno at Fri, 2004/02/06 - 6:00am

Maybe this is just an issue with my distribution (Slackware 9.1), but with the latest Qt 3.3 release, the Linux font in Konsole is broken again. Does anybody know where I have to look for the problem? Maybe it is just a misconfiguration or another compile option.

Steinchen


By Steinchen at Tue, 2004/02/10 - 6:00am

Yeah, When upgrading to KDE 3.2.1 on slackware the linux font on kosole no longer works. I am using bitstream at the moment. I think its a bug in qt. Hopefully it will get fixed soon. :)


By slackd, jawed y... at Tue, 2004/03/30 - 6:00am

Pages