OCT
25
2000

LinuxPlanet: A Look at KDE2

LinuxPlanet is the first one out with a closer look at KDE 2.0. "For years we've many of us made excuses for our Linux desktops. They did what we wanted, and what we wanted that they didn't do we learned to live without in order to take advantage of the robustness of the underlying operating system. But with KDE2 we no longer have to apologize for our desktops. Even with that annoying menu bug, KDE2 is the best desktop I've ever used on any platform." The bug that Dennis refers to was fixed a while back, and thankfully does not occur in the default KDE2 config. Update 10/26 9:20 AM by N: This bug is actually not present in the final KDE 2.0, it was found and squashed before the final release.

Comments

that made me want to install KDE2.0 right away.

Now, I'm just waiting for Bero to fix that RH 7.0 thingie, so it won't overwrite my KDE 1.2 settings.

Bero wrote something on Slashdot three days ago, but I haven't seen any remarks lately.

Any news on that front?


By Torben Skolde at Wed, 2000/10/25 - 5:00am

Did they really gave their own opinion about KDE?
KDE 2.0, the final release, is in my experience still an unstable beast.
Half of the apps are either not working or are just a port of the bad-designed KDE 1 apps.

This is not flame, just my experience and opinion.
KPaint is probably the worst KDE app ever.


By Anonymous at Wed, 2000/10/25 - 5:00am

Not to take anything away from the KDE guys, this is a wonderful achievement and I love them. However, they have squandered somewhat the moral
high ground that they had over the Gnome guys
for their terrible 1.0 release. I have been using
KDE2.0 for a day now and have come across several
infuriating annoyances and quite a few "show stoppers". I'm surprised that they were not picked
up in the testing. Anyway, here are some that I found (purely in the spirit of constructive criticism). I would appreciate any workarounds.

1) Kmail. Sometimes gets mail from the server and drops it into the ether. Thankfully I tested it before switching my mailbox over.
Sorting does not work properly.

2) The Kpanel is terribly buggy. I cannot add any applications to the panel. The icon appears on the panel, but when I click on it, I
simply get an error message.

3) Konqueror crashes reliably under many circumstances. Clicking on a postscript file displays it correctly once. If I click "back" and
click on the file again, crash! Also, the browser has a problem with accepting URLs. After a while, it refuses to take new URLs and keeps
going back to the old page. For some reason, Mozilla M18 has the exact same bug!

4) I hate to say this, but Koffice is unuseably buggy. Sometimes, it crashes while doing common operations. (Creating a table of
contents). It corrupts its own file so that when you try to read it, it crashes. The math fonts look terrible when printed.

5) Knode has not crashed on me so far, but there are so many small things that do not work right that I gave up on it.

KDE developers, here's hoping that 2.01 will get here quickly! And that brings me to another point:
why don't the KDE team do incremental releases
the way gnome guys do? Fix a bug in an app, say Kmail. It should be released in a form that does
not necessitate upgrading the whole of KDE. This is one area where Gnome has a significant advantage.

Magnus.


By Magnus Pym at Wed, 2000/10/25 - 5:00am

Why didn't you test KDE 2 in the release candidate stage then? To take the final and say it's wrong doesn't cut it for anyone, not even you...

Please: If you write HTML code then write correct code. An ending tag like </p> does imply there is a corresponding opening tag...

That's the reason your post doesn't render correctly under konqueror. By the way I just tested the opening of ps-files in this konqueror several times and as you see it didn't core dump or do anything stupid...

regards
Karl Günter Wünsch
(posted with konqueror)


By Karl Günter Wünsch at Wed, 2000/10/25 - 5:00am

Why didn't you test KDE 2 in the release candidate stage then? To take the final and say it's wrong doesn't cut it for anyone, not even you...

(Raises hand) Maybe Magnus didn't, but I did.

I tested KDE 1.91 through to the final release...and you know what? I could see comments like this comming. When the release date only shifted by a week, and it still had substantial showstoppers, I expected that the 2.0 release would not be stable enough to recommend. KDE 2.0 is interesting -- as a preview. The beta and pre-releases were exceedingly difficult to compile and install, thus cutting into my ability to comment on it at all...let alone contribute.

Take this as someone who doesn't have a clue, or is not paying attention, or is just stupid if you want...I don't expect much different.

The typical process I'd follow to test KDE went something like this; wipe dedicated KDE 2.x test system clean, check directions, read mailing list, grab source or RPMs and compile/install, encounter showstopper, check mailing list, add/update supporting files, wipe out KDE 1.x and 1.9x, run Gnome to verify X is OK, recompile from source, compile and install, other showstopper, wipe out test system and reinstall OS, told 'use CVS', used CVS (scant directions), recompile and install, encounter other showstopper, told 'RedHat has it out for KDE', update more supporting files, told 'obviously you don't know what you're doing', .... Maybe I don't, maybe I didn't have the right libraries and the right environment settings, but you can't fault me for trying!

At one point early in the 1.9x series when I had a partially working test system, I offered to give some time creating KOffice templates (open job #10?), but nobody seemed interested in the offer. Maybe they knew how much of a moron I was. Either way, last time I checked the job was still unclaimed.

I'm about to wipe out my CVS copy again and give it another try...maybe 2.0+ will be better? Can you blame me for being unenthusiastic at this point? Probably...


By Andy Longton at Wed, 2000/10/25 - 5:00am

Andy, what does it say when a lot of people find KDE2 stable and very usable, and you don't? Perhaps could it be something you're doing wrong? Like maybe you could have a corrupt .kde from all the betas and alphas you have been testing?

Or else you have a vastly different idea of what a "showstopper" is. Every little bug is not a showstopper. Crashes and instability or dangerous behavior are.


By KDE User at Wed, 2000/10/25 - 5:00am

KDE User, read the ... well ... KDE User mailing list. Archives if you have to. In the past few days, the advice has ranged from 'compile from source' to redhat/mandrake/SuSE 'are doing something wrong'. Yet, the directions aren't consistant, and change as new people report different problems. Ignore the evidence of others if you want.

Showstopper: A defect that makes a system unusable as designed where there are no user-level workarounds. (If you want other definitions, I'll consult my VV&T notes...though they are substantially the same.)

Examples: Taskbar, Control Center, and Konq. dying. KDE 1.x apps not working or not working at all or as usual. Failure of KDE 2.x to load completely.

I'll use KDE 2.0, but I'm not under any illusions that it's high quality software at this time. It has promise...it's just not there yet. (But, why listen to me. I'm obviously a moron or a troll.)


By Andy Longton at Thu, 2000/10/26 - 5:00am

With a name like Andy, you most certainly must be a troll.

I realize this thread is probably dead, since October was 8 months ago and KDE 3 is now out. However, I hope Andy is notified of this response and reads it.

I represent a computer company in Washington state...no I'm not Bill Gates. We have installed KDE2 properly and have kept close watch over our production machine. KDE2 does crash and is not a finished product. In fact, I hesitate to call Linux and Linux-based software products. Only if the software is closed source would I consider it a product. Otherwise I would call them tools.

We would be repeating the sins of our fathers if we called our software finished while it is obviously not. Afterall, that is what Microsoft has always done.

KDE3 has not yet crashed on us, but I expect it too at least once in the next three months. I hope I am proven wrong.

Quirks in the placement of objects on the screen is usually not a showstopper. however, if it prohibits your use of the software then it is! Buttons not responding to activity is typically an issue of patience or dire need of ungrades, but I have seen programs in Linux exhibit this behavior authentically.

We could go on and on. KDE2 is a good desktop. It is better than Gnome in the respect of not having Nautilus integrated into the file browsing and every other creepy corner. Nautilus is a resource hog. Also, Gnome has a dark feel...trolls must prefer gnomes...they taste good. KDE has a light and cheerful look. I have had more programs fail to launch in Gnome than I have in KDE. The light feel and the ability to launch most programs are the two sole reasons we use KDE on every computer at our business. I think we'll stick with it.

Nashledanou!


By General REC at Fri, 2002/05/17 - 5:00am

Which version of KDE do you use?

I tested the kpanel (2) and the konqueror (3) and did the same things you described without any problems. What is you problem with KNode? I use it for more than 8 weeks and it works perfect for me. I am compiling from CVS but this will not make much difference to the final relase.

KOffice has indeed several bugs but every week things getting better. And comparing with M$ Office and StarOffice I like KOffice much more (it is faster and the others have bugs as well).

I agree with you critics about the upgrading mechanism of KDE. But if I remember correctly the KDE developers attack this problem and will update their packages more often.

ciao, Marco


By Marco Krohn at Wed, 2000/10/25 - 5:00am

> Which version of KDE do you use?

Sorry, you wrote that you use KDE2.0, my fault.


By Marco Krohn at Wed, 2000/10/25 - 5:00am

Hi,

Sorry for the bad HTML formatting on the previous post.Are you saying that you cannot reproduce these bugs with your setup?

I have a Mandrake 7.1 system. I have compiled
KDE2 myself from source and put it in /opt.

Try the following:

K-Menu-> Panel Menu -> Add -> Application -> Internet -> Netscape.

The netscape icon appears on the panel. Now click on it. I get a window with the following message:

The desktop entry file
/home/magnus/.kde2/share/applnk/Internet/Netscape.desktop has no type=...entry.

As for Konqueror, are you saying that you have no
problems with new URLs being accepted? Well, it is probably a setup-specific bug then. What happens is that after visiting a few sites, Konqueror does not accept any more URLs and keeps going back to the last site visited. But I do not know why it happens for me and not you.

I checked your claim about PS files. I made a mistake. The crashing depends on the specific PS file being opened. It looks like ps files made from dvips are handled without problem. I have a
postscript file that was I unfortunately cannot share (proprietary info) that appears to have been
created with some wierd app. I can open the file
with ghostview without problems. I can even open
it with kghostview from within Konqueror once. If I try to do it again in the same session, it crashes. If I can reproduce this with some non-propritary document, I will send in a bug report on this.

For Kmail: I tested this and am able to observe cases when it obtained messages in the server and did not put the message into my inbox. I'm not sure about how to generate a test case for this, but I assure you that it does happen. Also, try sorting the messages in a folder based on the date. Every once in a while, the sorting goes haywire.

Magnus


By Magnus Pym at Wed, 2000/10/25 - 5:00am

As much as I used to like Mandrake, since 7.0 it's been exceedingly buggy. I've had similar problems with KDE2 pre-releases on Mandrake 7.1 that no one else seemed to have.

As much as I love Mandrake's install and configuration utils, I'm moving to Debian as soon as Woody is officially released.


By Aaron Traas at Wed, 2000/10/25 - 5:00am

I have to agree about Mandrake. After having quite a few problems myself with 7.0 ( release versions of many apps wouldn't compile properly, or wouldnt run quite right once they did) which, from everything I could find out, I shouldn't have been having, I moved back to RedHat 6.2, and have hardly had a problem, since.
I'm currently running a CVS version of KDE 2.0 without a snag, when I could barely get it to compile on Mandrake 7.0 ( yes tried with exact same tar balls, just recently moved to using CVS )


By Eddy at Wed, 2000/10/25 - 5:00am

well I use the current CVS - so maybe some things have been fixed since KDE2, but I did not encounter such problems with pre-KDE2 versions

adding Netsacpe this way works fine for me

No problems with konqueror accepting URLs - even working for hours. There seems to be a problem with redirects and going BACK.

as for PS-files you might have problems with encrypted files.

as for kmail - I receive many mails per day which I fetch from my POP3 server - for many month I did not encounter a loss of mails.

as for sorting - did you check if the header shows "Date of arrival" - then it's sorted by the date of arrival but shows the actual date

hope that helps

ferdinand


By Ferdinand Gassauer at Wed, 2000/10/25 - 5:00am

I am really not getting this. I have mandrake 7.1 with KDE 2 compiled in the /opt/kde2 directory and it has been practically perfect for me for about a month. I have the final release in now and it's great.

Obviously I cannot duplicate the bugs mentioned here. My question is did you compile QT too? I found that with the qt 2.2.1 rpm from Mandrake that it did not behave as expected and compiled qt myself to be sure. Additionally I found on at least one occasion during the beta process for some reason some residual files from when I moved qt giving me problems. I wiped the kde 2 directory and reinstalled.

Finally I have posted at virtualartisans.com/linux/mandrake/ my instructions for compiling KDE 2 on Mandrake 7.1. I can think of one other potential issue. The latest cooker seems to have gcc 2.96 for some reason. I would have thought something would have been learned from Red Hat's mistake. You should be compiling with gcc 2.95.2 preferably. (2.96 is a beta with C++ problems)

KDE 2 may be a hair short of flawless and still not have every conceivable application and feature however it has ceded nothing to any other desktop in terms of reliability or function. If you are having a bad experience it is not really rational to assume everyone else has somehow received hyper-functional code. ;-)


By Eric Laffoon at Wed, 2000/10/25 - 5:00am

Guys,

Based on suggestions I received, I deleted
my .kde2 directory and restarted KDE2. There
seems to be substantial improvement to the overall stability. Some of the Kmail and Knode
problems have gone away, and the panel is
working mostly OK now. The only problem is
that I cannot get the taskbar to disengage
from the panel.

Maybe the baggage that remained in .kde2 from the
betas caused some of the problems. I guess this
should be added to the KDE2 HOWTO somewhere?

Magnus.


By Magnus Pym at Thu, 2000/10/26 - 5:00am

Woohoo! Good to hear.

Unfortunately, the taskbar does not "disengage" in KDE2. Some code was there, but the proper framework was not. It was decided that this feature would have to wait for KDE 2.1.

Cheers,
Navin.


By Navindra Umanee at Thu, 2000/10/26 - 5:00am

I have to agree as well... Mandrake 7 and I've been using KDE 2 from CVS for around 3 months, no more problems than the known bugs. must admit, my mandrake is a very minimal install just the basics needed for a linux system.


By David at Fri, 2000/10/27 - 5:00am

I built KDE 2.0 from source on a RedHat 6.2 box
that I use at work. I tried what you said above
and when I clicked on the new Netscape icon on the panel I got... a Netscape window pretty much
the way you would expect.

I've been running various KDE 2.0 betas since
Beta1 came out and I've never experienced the
kind of URL cycling problem you describe with
Konqueror. (I have experienced it on Windows
with MSIE, though. Weird.)

I have experienced some crash problems with viewing PS files, but I think the problem is
with the PS viewer, not with Konqueror. So far
every such crash I've had has been fully reproducible in the stand-alone PS viewer app.
Frankly, I would agree that that one isn't quite
up to snuff; OTOH it isn't really any different
from the PS viewer in KDE 1.1.2.

In general, I'm quite impressed with KDE 2.0. I think Konqueror's web browsing is really good. I know of a few pages that have rendering glitches (but which are still perfectly usable). The main issues I have with it are Java and JavaScript related (some pages that use JavaScript for form submission don't work at all). But Konqueror has replaced Netscape as my
primary browser; I just keep Netscape around to
handle the few pages that Konqueror still won't.

Moreover, as a platform for further development
KDE 2.0 kicks butt. I expect to see a flood of
powerful, high-quality apps coming out for this
environment in the relatively near future.

Kyle Haight


By Kyle Haight at Thu, 2000/10/26 - 5:00am

I tried this (using knode instead of nutscrape). Worked fine. SOunds like you have some lone kde config file somewhere that is acting up. When I installed KDE 2.0 (compiled from source on Mandrake 7.1 without a KDE 1.1.2 install) I removed my old KDE 2.0 RC2 install and completely reinstalled it.

Everything works beautifully so far. And I can't wait for Mandrake 7.2

Oh yeah, posted using Konqueror...

Tim


By Tim_F at Thu, 2000/10/26 - 5:00am

KMail has never dropped stuff in the ether for me! What are you talking about?


By David Simon at Wed, 2000/10/25 - 5:00am

I installed KDE 2 final yesterday on my SuSE 7.0 and was very impressed. There is major progress im comparison to the last beta i had installed before (1.93)

But, nevertheless, there are some annoying bugs. Several applications crash without any obvious cause. Especially koffice seems rather unstable to me.

But the thing I'm most unhappy about is that i can't get working neither kscd nor kmidi. kscd simply doesn't recognize the cd, though it's no problem to play it with Xmcd, and kmidi crashes while starting...

Is there anyone who had similar problems and found a solution for them?

Greetings

Christoph


By Christoph Maurer at Thu, 2000/10/26 - 5:00am

1) Kmail. Sometimes gets mail from the server and drops it into the ether.

If you are using a pop server and can reproduce this bug then give me a mail and I'll try to help you debug the problem. (It doesn't have to happen on demand, even being able to reproduce it once every few days is enough).

If you use a local account you should ensure file locking is set up correctly as described in http://lists.kde.org/?l=kmail&m=97163225926136&w=2

It does sound as if KDE did not install correctly for you. I don't experience any of the problems you do with the apps I use. I have received somewhat similar complaints from people whose KDE installs have only partially succeeded. (But these people have not mentioned any mail losing bugs)


By Don Sanders at Fri, 2000/10/27 - 5:00am

> This is not flame, just my experience and opinion.

Sorry, but it really sounds like a flame.
Writing as anonymous and give just general statements like: "is an unstable beast" is typical for flamers.

No insult intended, I just want to explain why one can think it is meant as a flame.

Ok, try to give us some examples of things that are unstable. Which apps are bad-designed or bad ported? Or even better write bug reports to bugs.kde.org. This will help us all to make kde a better place ;-)

ciao, Marco


By Marco Krohn at Wed, 2000/10/25 - 5:00am

> Writing as anonymous and give just general statements like: "is an unstable beast" is typical for flamers.

I also wrote "in my experience"...


By Anonymous at Wed, 2000/10/25 - 5:00am

> Ok, try to give us some examples of things that are unstable.

* Konqueror crash before I see the main window (beta 2 is much more stable).
* Same story for KOffice.
* KMail still doesn't have full thread support.
* I still can't configure the file dialog to do double-click-to-open-a-file (I hate the one-click-to-do-it-all "feature" ala Win98).
* No TAB completion in the file dialog like GTK+/Gnome.
* Focus system is terrible IMHO.
* The apps load much slower than KDE 1 or Gnome apps. Mainly because of DCOP (yes I know everybody claim it's fast, but it just doesn't feel like fast to me).
* Some apps still looks ugly (like KEdit/KWrite).
* No floating toolbars like in KDE 1 and Gnome.
* Panel is terribily unstable. I can't even add an applet! I lost my taskbar and I can't get it back!
* Al some more things I can't remember right now...

Yes I'm using KDE 2.
And yes both QT and KDE are compiled without exceptions.


By Anonymous at Wed, 2000/10/25 - 5:00am

> Konqueror crash before I see the main window

Obviously an install issue. Do you think they'd release KDE2.0 if Konqueror had that problem? :)

>Focus system is terrible IMHO

So change it to whatever scheme suits you. Look in the control center.

>Some apps still looks ugly (like KEdit/KWrite)

How's that? Have you tried changing style/theme/icon theme?

>No floating toolbars like in KDE 1 and Gnome.

This I think will be back in KDE 2.1.


By Haakon Nilsen at Wed, 2000/10/25 - 5:00am

You are obviously trolling since there is no KPaint in KDE2, is there? The paint app is pixie which Mosfet pulled at the last minute.


By KDE User at Wed, 2000/10/25 - 5:00am

Download kdeaddutils.rpm and see it for yourself.
Now what were you saying about no KPaint in KDE2?

And Pixie is not an image editor, but an image VIEWER!
So who's trolling here now?


By Anonymous at Wed, 2000/10/25 - 5:00am

Download kdeaddutils.rpm and see it for yourself.
Now what were you saying about no KPaint in KDE2?

Freaking confused people!!! kpaint is so not part of KDE 2 it is not even funny. You will find it in the nonbeta package and it has always been a seperate compile. The last work done on it was something like a year ago!

If your distro has included non release KDE programs in the package to have more stuff avaialble great. But... it is not part of the KDE 2 release. It is in a package of unstable applications available for people to bitch about.

That may not be trolling... but it is certainly getting to the bottom of the barrel.

I would say if you are looking this hard for reasons to dislike it then don't use it! Nobody here who enjoys the functionality and stability of KDE really cares about kpaint and if they did they would work on getting developers for it.


By Eric Laffoon at Wed, 2000/10/25 - 5:00am

For your information: Pixie is also an image editor. It has more than 20 filters you can aply
to your images. You have obviously never tried to use them.


By Zeljko Vukman at Thu, 2000/10/26 - 5:00am

So Pixie has filters.
It still isn't an image editor!
Can you draw lines with Pixie?
Or ovals? Or rectangles?
No you can't! So Pixie is not an image editor!


By Anonymous at Fri, 2000/10/27 - 5:00am

No, when you change allready created images - you edit them (for example by applaying filters). When you draw lines, ovals, rectangles - you create images. Pixie is not an image creator, but it is an editor.


By Zeljko Vukman at Fri, 2000/10/27 - 5:00am

i installed kde 1.9 and it was a mess
a screwed my desktop......

then ........

i trashed all the kde packages
and installed kde 2.0
Works fine for me.... no problem at all

worked first time .... impressive !!!

Y


By Wavlane at Wed, 2000/11/22 - 6:00am

yeah everybody seems to have problem with 2.0
well if you upgraded your old kde 1.x.x
and you did not trash all old /lib....
or backed them up dont expect the impossible
i first tried without cleaning my /lib
screwed everything was fu**ed up kfm & kconqueror
was running at the time ????????????

i then backed up all kde's /lib

and installed all kde2 packages
from my home directory at the bash prompt
by doing.......>

rpm --nodeps --force -i *rpm

I have no problem Yet and installed kde2
for a month now and my pc as been rebooted
like 2 time max.


By Wavlane at Wed, 2000/11/22 - 6:00am

Is there anyone out there willing to post their "top" output? I would like to get some idea of KDE2's footprint before trying it on my 64MB machine. Thanks.


By chris at Wed, 2000/10/25 - 5:00am

Y'll be pleased ;-)

The data collected come from a 64MB Pentium MMX 200MHz and XFree 4.

with SuSE 7.0 KDE2 rpms the minimal memory usage after startup is about 30MB

after opening kword,kspread,kmail,knode,kpm, konqueror webbrowser and konqueror filemanager, and kcontrol the "momory used" is 40MB.

hope that this convices you

ferdinand


By Ferdinand Gassauer at Wed, 2000/10/25 - 5:00am

You will gain about 2MB RAM with -no-exceptions
The file size is ~5.5MB without and ~7.5MB with them for libqt


By anon at Wed, 2000/10/25 - 5:00am

how on earth can you run it on a 200mhz machine? i am compiling kde + qt from source (slackware 7.1) on a 450mhz machine w/96mb of ram and konqueror is intolerably slow. which pisses me off because i like its UI a lot and want to use it as my main browser!

what am i doing wrong - or, what could i do to increase performance? i compiled QT with no exceptions already... are there flags to kde to make it fast and small?

help!!
thanks,
steve


By steve havelka at Mon, 2000/10/30 - 6:00am

I have a 64MO laptop.
And observe a better speed and memory usage (around 30%) after the compilation of QT
without exception.
I don't see any difference in stability.
The way to do it :
- download the QT source
- open $QTDIR/configs/linux-g++-shared (or freebsd-g++-shared or whatever you use) with text editor
- add "-fno-exceptions" to SYSCONF-CXXFLAGS.
- then ./configure and make.
That's all.
Your QT libqt.so.2.2.x is ~ 5MO.


By thil at Thu, 2000/10/26 - 5:00am

Well, I have kde2 running (as part of the Peanut distro) on a 150MHz system with only 68k memory. Loading takes about 25-30 sec.

It is noticeably slower than the kde-1 running on a similarly configured 120MHz system. But there's no other way I can run koffice, so I live with the slow performance.


By Ken at Thu, 2002/06/06 - 5:00am

The article mentions that menus don't work with focus follows mouse. Is that indeed the case? I was thinking about upgrading within the next couple of days, but this problem would certainly make me wait for the next release, as I use focus follows mouse all day.

Claus


By Claus Wilke at Wed, 2000/10/25 - 5:00am

Not on SuSE 7.0

it works fine with Xfree 336 and 4.0.0 right out of the box

ferdinand


By Ferdinand Gassauer at Wed, 2000/10/25 - 5:00am

Great. That's the setup I wanted to try.

Claus


By Claus Wilke at Wed, 2000/10/25 - 5:00am

LinuxToday has better comments than you do.


By KDE User at Wed, 2000/10/25 - 5:00am

Hi all,

I don't why I can view a jpeg and gif file on my KDE2. I can't select a jpeg file as my bacground image either.
I think have compiled QT and all the KDE2 packages correctly.
I specified flags for QT :
./configure -shared -sm -gif -system-zlib -system-libpng -system-jpeg
The order KDE2 package compiled:
KDESupport-2.0
KDElibs-2.0
KDEBase-2.0
KDEAdmin
etc
Any body can help me? I now there must be something wrong since for other people its working, but I just can't find it.

Jamal


By jamal at Thu, 2000/10/26 - 5:00am

Don't use:

-system-libpng -system-jpeg

if they are not installed, maybe they are not. Have you installed kdegraphics???


By David at Fri, 2000/10/27 - 5:00am

How do I detect that my RH 6.1 has library jpeg and png that Qt using. What version of these libraries that works with QT-2.2.1?
I have compiled and installed all the 13 packages including kdegraphics-2.0, with order :
1. QT-2.2.1
2. kdesupport
3. kdelibs
4. kdebase
etc....
My question:
if I don't specify flags:
-system-libpng -system-jpeg
Is Qt will directly use its jpeg and png library?
Thanks...


By jamal at Sat, 2000/10/28 - 5:00am